Bug 1913793 - NPE on host reinstall UI dialog
Summary: NPE on host reinstall UI dialog
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.4.4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Arik
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-07 15:58 UTC by Petr Matyáš
Modified: 2021-07-06 07:28 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:26 UTC
oVirt Team: Virt
ahadas: ovirt-4.4?
aoconnor: blocker-
ahadas: planning_ack?
ahadas: devel_ack+
pm-rhel: testing_ack+


Attachments (Terms of Use)
engine log (6.31 MB, text/plain)
2021-01-07 15:58 UTC, Petr Matyáš
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114779 0 master MERGED core: identify hosted engine VM by origin type 2021-05-13 20:04:16 UTC

Description Petr Matyáš 2021-01-07 15:58:05 UTC
Created attachment 1745328 [details]
engine log

Description of problem:
After update of RHV to latest version, I can't reinstall hosts as I always get cmd validation failure on confirmation and huge NPE in engine log.

Version-Release number of selected component (if applicable):
ovirt-engine-4.4.4.7-0.1.el8ev.noarch

How reproducible:
always

Steps to Reproduce:
1. update RHV to latest version
2. try to reinstall a host
3.

Actual results:
unable to confirm UI dialogue

Expected results:
should be working

Additional info:
2021-01-07 16:22:41,884+01 ERROR [org.ovirt.engine.core.bll.hostdeploy.InstallVdsCommand] (default task-4) [9014d0d5-db4c-41c1-9830-fc1310b73d4a] Error during ValidateFailure.: java.lang.NullPointerException
        at deployment.engine.ear.bll.jar//org.ovirt.engine.core.bll.hostedengine.HostedEngineHelper.getStoragePoolId(HostedEngineHelper.java:103)
        at deployment.engine.ear.bll.jar//org.ovirt.engine.core.bll.validator.HostValidator.supportsDeployingHostedEngine(HostValidator.java:178)
        at deployment.engine.ear.bll.jar//org.ovirt.engine.core.bll.hostdeploy.UpdateVdsCommand.validate(UpdateVdsCommand.java:155)

Comment 1 Arik 2021-01-07 16:43:35 UTC
Did you rename the hosted-engine VM by any chance?

Comment 2 Petr Matyáš 2021-01-08 09:01:59 UTC
Yes I did. Should be working like any other name.

Comment 3 Arik 2021-01-08 10:56:27 UTC
Yes, but the hosted engine is a bit unique in that sense - the system needs to know which VM it is.
With new deployments of hosted engine, the engine can figure this out using the 'origin' field of the VM but in this case, it's done by the VM name.

So in the long term, this needs to be changed.
But in the short term, you can workaround that by setting the 'HostedEngineVmName' config with the new name of the hosted engine VM.

Comment 4 Michal Skrivanek 2021-04-07 16:38:07 UTC
so isn't this just a problem of engine-rename command not doing it?

Comment 5 Arik 2021-04-07 18:52:22 UTC
no, because you can rename the hosted engine vm from the UI, right?

Comment 6 Michal Skrivanek 2021-04-08 07:41:13 UTC
(In reply to Arik from comment #5)
> no, because you can rename the hosted engine vm from the UI, right?

oh, that way. why is it not mentioned in the bug description?

Comment 7 Nikolai Sednev 2021-06-16 21:20:37 UTC
1.Deploy fresh HE over NFS or other storage type.
2.Change Engine VM's name via UI from "HostedEngine" to "Director1".
3.Add additional hosted engine ha host.

You will receive this failure:
Operation Canceled
Error while executing action: Cannot add Host. You are using an unmanaged hosted engine VM. Please add the first storage domain in order to start the hosted engine import process.

4.Change back Engine VM's name via UI from "Director1" to "HostedEngine".
5.Add additional hosted engine ha host.
6.Additional ha-host successfully added.

I see that the root cause is not fixed.
Moving back to assigned.

Comment 8 RHEL Program Management 2021-06-16 21:20:45 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 9 Nikolai Sednev 2021-06-16 21:23:59 UTC
Tested with: rhvm-appliance-4.4-20210527.0.el8ev.x86_64 which is ovirt-engine-setup-4.4.6.8-0.1.el8ev.noarch.
Tested on:
ovirt-hosted-engine-setup-2.5.1-1.el8ev.noarch
ovirt-hosted-engine-ha-2.4.7-1.el8ev.noarch
Linux 4.18.0-305.6.1.el8_4.x86_64 #1 SMP Mon Jun 7 10:18:09 EDT 2021 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 8.4 (Ootpa)

Might be the fix was not yet fetched to this version, rechecking with 4.4.7 latest bits on the engine and moveing back to ON_QA for this matter.

Comment 10 Nikolai Sednev 2021-06-16 22:47:13 UTC
Retested on ovirt-engine-setup-4.4.7.3-0.3.el8ev.noarch.
2.Change Engine VM's name via UI from "HostedEngine" to "Director1".
3.Add additional hosted engine ha host.
4.Host was successfully added without any errors.
I also tried to reinstall already added ha-host and also with success.

Moving to verified.

Comment 11 Sandro Bonazzola 2021-07-06 07:28:26 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.