Bug 1913819 - python-BTrees fails to build with new RTD theme: cd: doc/_build/html/_static/fonts: No such file or directory
Summary: python-BTrees fails to build with new RTD theme: cd: doc/_build/html/_static/...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-BTrees
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-07 16:52 UTC by Tomáš Hrnčiar
Modified: 2021-01-07 17:16 UTC (History)
3 users (show)

Fixed In Version: python-BTrees-4.7.2-4.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-07 17:16:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-07 16:52:10 UTC
python-BTrees fails to build with Python 3.10.0a4.

+ cd docs/_build/html/_static/fonts
/var/tmp/rpm-tmp.Mfk6Vu: line 42: cd: docs/_build/html/_static/fonts: No such file or directory

It is caused by updated RTD scheme.
https://src.fedoraproject.org/rpms/python-BTrees/blob/master/f/python-BTrees.spec#_91

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01865079-python-BTrees/

For all our attempts to build python-BTrees with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-BTrees/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Jerry James 2021-01-07 17:16:23 UTC
Fixed in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.