Bug 191383 - loopback interface (lo) not configured during kickstart install from DVD
loopback interface (lo) not configured during kickstart install from DVD
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 10:35 EDT by Andreas Luik
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 14:44:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Luik 2006-05-11 10:35:36 EDT
Description of problem:

I observed that the lookback network interface (lo) is not configured
while the %post scripts runs in a kickstart installation from DVD, whereas
it is properly configured if installing from an install server (via NFS).
This seems to be inconsistent to me.
(The resulting problem is that "cupsd" cannot be started and configured
in the %post installation script.)


Version-Release number of selected component (if applicable):

anaconda-9.1.6.8-2.RHEL

How reproducible:

always

Steps to Reproduce:
1. run kickstart installation from DVD
2. in the %post script, check for lookback interface (lo), e.g. with ifconfig

Actual results:

"ifconfig lo" reports no inet address

Expected results:

"ifconfig lo" reports inet addr 127.0.0.1, "UP RUNNING"
(as it does when installing from an install server via network, e.g. NFS)


Additional info:
Comment 1 Jeremy Katz 2006-05-15 14:44:36 EDT
We only enable network interfaces on network installs.  Changing this in the
context of a Red Hat Enterprise Linux update is too risky for customers who are
dependent on existing behavior.  See bug 191424 to track discussion of changing
this for future releases

Note You need to log in before you can comment on or make changes to this bug.