Bug 191387 - RFE: support for perl-Spreadsheet-ParseExcel
RFE: support for perl-Spreadsheet-ParseExcel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Unicode-Map (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 191350
  Show dependency treegraph
 
Reported: 2006-05-11 11:13 EDT by Michael A. Peters
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 12:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2006-05-11 11:13:37 EDT
RFE - support for perl-Spreadsheet-ParseExcel

Spreadsheet::ParseExcel is a perl module that requires modification to
Unicode::Map in order to fully function.

At a minimum, the following lines need to be added to Unicode/Map/REGISTRY:

name:    CP932Excel
srcURL:  $SrcUnicode/VENDORS/MICSFT/WINDOWS/CP932.TXT
src:     $DestUnicode/VENDORS/MICSFT/WINDOWS/CP932.TXT
map:     (which you copied directry)/CP932Excel.map
# Don't remove this line



It would not be appropriate for perl-Spreadsheet-ParseExcel to modify that file
itself, since it does not own it.

-=-

Additionally, there is the issue of the CP932Excel.map file

perl-Spreadsheet-ParseExcel is a noarch package, but the correct place for the
map file is in an arch dependent directory (ie
i386-linux-thread-multi/Unicode/Map/MS/WIN/ )

There are two options - I can install the file as part of
perl-Spreadsheet-ParseExcel and make the package arch dependent, or the file can
be added to the Unicode::Map package.

I would prefer the latter, but would be willing to do the former.

-=-
The README file describing this can be viewed at

http://search.cpan.org/src/KWITKNR/Spreadsheet-ParseExcel-0.2603/README

The needed map file is at

http://search.cpan.org/src/KWITKNR/Spreadsheet-ParseExcel-0.2603/CP932Excel.map
Comment 1 Michael A. Peters 2006-05-15 02:50:25 EDT
I went ahead and had perl-Spreadsheet-ParseExcel install the map file.
So all that needs to be done for the proper japanese support is the modification
to the Unicode/Map/REGISTRY file as described.
Comment 2 Aurelien Bompard 2006-08-30 12:18:06 EDT
Done for FC6. Sorry for this extra-lenghty reply, but I packaged
perl-Unicode-Map only as a dependency. If you're interested in this package,
please feel free to take it over.

Note You need to log in before you can comment on or make changes to this bug.