Bug 1914144 - python-colorspacious: FTBFS in Fedora rawhide - Extension error: You must configure the bibtex_bibfiles setting
Summary: python-colorspacious: FTBFS in Fedora rawhide - Extension error: You must con...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-colorspacious
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-08 08:30 UTC by Tomáš Hrnčiar
Modified: 2021-01-25 23:20 UTC (History)
1 user (show)

Fixed In Version: python-colorspacious-1.1.2-12.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-25 23:20:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-08 08:30:52 UTC
Description of problem:
Package python-colorspacious fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.1.2-11.fc33

Steps to Reproduce:
koji build --scratch f34 python-colorspacious-1.1.2-11.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-colorspacious

Extension error:
You must configure the bibtex_bibfiles setting
make: *** [Makefile:53: html] Error 2
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.hSmIBs (%build)
    Bad exit status from /var/tmp/rpm-tmp.hSmIBs (%build)
Child return code was: 1
EXCEPTION: [Error()]
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/mockbuild/trace_decorator.py", line 93, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.9/site-packages/mockbuild/util.py", line 789, in do_with_status
    raise exception.Error("Command failed: \n # %s\n%s" % (command, output), child.returncode)
mockbuild.exception.Error: Command failed: 
 # bash --login -c /usr/bin/rpmbuild -bb --target noarch --nodeps /builddir/build/SPECS/python-colorspacious.spec

Comment 1 Fedora Release Engineering 2021-01-24 04:22:33 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-05).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Dominik 'Rathann' Mierzejewski 2021-01-25 22:54:13 UTC
Looks like sphinx build config needs to be ported to sphinxcontrib-bibtex 2.0.


Note You need to log in before you can comment on or make changes to this bug.