Bug 191419 - fbdev(4) driver broken
Summary: fbdev(4) driver broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fbdev
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker OLPCBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-11 19:29 UTC by David Zeuthen
Modified: 2013-03-06 03:45 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-06-23 00:17:49 UTC


Attachments (Terms of Use)

Description David Zeuthen 2006-05-11 19:29:42 UTC
Description of problem:

(EE) FBDEV(0): FBIOBLANK: Invalid Argument

See also

 http://people.freedesktop.org/~david/qemu-fails-on-fbdev.png

Reproduced on radeonfb, the kernel fbdev driver used on qemu, vesa fbdev on i830
(according to krh) and also imacfb (out of tree experimental driver) on the
Macbook Pro. (the latter works in Ubuntu btw and inspecting their xorg packages
shows little divergence from ours so I suspect it may be a kernel issue?)

We need this to work for OLPC for booting OS images on regular laptops. Please
advise. Thanks.

Version-Release number of selected component (if applicable):

xorg-x11-drv-fbdev-0.2.0-1

How reproducible:

Always

Comment 1 David Zeuthen 2006-05-15 15:16:28 UTC
Adding to FC6Blocker

Comment 2 Adam Jackson 2006-05-15 17:40:38 UTC
that error message isn't actually fatal, just irritating.  i think krh was
looking into the fix for this, but you should be able to say Option "ShadowFB"
"off" as a workaround for now.

Comment 3 Kevin E. Martin 2006-05-18 21:15:45 UTC
There were two issues for this one.

The first was the crasher, which was fixed by krh's patch in:
    https://bugs.freedesktop.org/show_bug.cgi?id=6940

The second was caused by recent miext/shadow changes, which I've just fixed
upstream (it also caused the VESA driver to fail).

Both are now checked in upstream and should be included in the next driver spin.


Comment 4 Adam Jackson 2006-06-23 00:17:49 UTC
fixed in 0.3.0-1


Note You need to log in before you can comment on or make changes to this bug.