Bug 191427 - bogus /var/run/yum.pid
Summary: bogus /var/run/yum.pid
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-11 20:58 UTC by Ben Greear
Modified: 2014-01-21 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 17:54:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Greear 2006-05-11 20:58:16 UTC
Description of problem:

Installed FC5 on x86-64 system.  Tried to run package updater,
and it just sat there not doing anything useful.  Killed it
by clicking the 'x' in the GUI.  Tried 'yum update' from the
console, but that failed to run because /var/run/yum.pid
existed.  However, there is no process existing to match that
pid.

yum should check not only for that file's existance, but should
also verify that the process exists and is a yum process.  Otherwise,
it should clean up it's mess and carry on.  It should probably use
the open and unlink trick so that any time yum dies, for any reason,
the yum.pid file goes away.


Version-Release number of selected component (if applicable):

yum 2.6.0
not sure about pup, it's whatever comes with FC5 ISO images.


How reproducible:

2/2 so far.

Steps to Reproduce:
1.
See description above.
2.
3.
  
Actual results:

package updater hangs doing nothing useful.

Expected results:

package updater should at least give an error message.
yum should clean up it's yum.pid file.

Additional info:

Comment 1 Seth Vidal 2006-05-12 17:52:23 UTC
the doLock() method in yum checks if the pid is still running when dealing with
the locker.

I'll test it out but this code hasn't changed much


Comment 2 Seth Vidal 2006-05-12 17:54:37 UTC
I just tested this.
if the process id noted in /var/run/yum.pid is no longer running yum will purge
the old pidfile and move along.

Are you sure the other process was dead?

closing as worksforme until I can replicate it.



Note You need to log in before you can comment on or make changes to this bug.