Bug 1914306 - python-msrest fails to build with new RTD theme: cd: doc/_build/html/_static/fonts: No such file or directory [NEEDINFO]
Summary: python-msrest fails to build with new RTD theme: cd: doc/_build/html/_static/...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-msrest
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-08 15:04 UTC by Tomáš Hrnčiar
Modified: 2021-02-15 10:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-15 10:46:14 UTC
Type: Bug
releng: needinfo? (pikachu.2014)


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-08 15:04:27 UTC
Description of problem:
Package python-msrest fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.6.19-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-msrest-0.6.19-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-msrest

The HTML pages are in _build/html.
+ rm _build/html/.buildinfo
+ popd
~/build/BUILD/msrest-for-python-0.6.19
+ pushd ./doc/_build/html/_static/fonts/
/var/tmp/rpm-tmp.rV0Not: line 43: pushd: ./doc/_build/html/_static/fonts/: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.rV0Not (%build)

It is caused by updated RTD scheme.
https://src.fedoraproject.org/rpms/python-msrest/blob/master/f/python-msrest.spec#_78

Comment 1 Fedora Release Engineering 2021-01-24 04:22:42 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-05).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Ben Cotton 2021-02-09 15:38:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Fedora Release Engineering 2021-02-14 04:22:30 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-05).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html


Note You need to log in before you can comment on or make changes to this bug.