Bug 1914338 - python-texext fails to build with Python 3.10: free(): invalid pointer
Summary: python-texext fails to build with Python 3.10: free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 1904379
Alias: None
Product: Fedora
Classification: Fedora
Component: python-texext
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1904379
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-08 15:42 UTC by Miro Hrončok
Modified: 2021-01-09 10:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-09 10:56:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-01-08 15:42:30 UTC
python-texext fails to build with Python 3.10.0a4.

+ rst2html --no-datestamp README.rst README.html
free(): invalid pointer
/var/tmp/rpm-tmp.hcuS2t: line 36:    31 Aborted                 (core dumped) rst2html --no-datestamp README.rst README.html

I believe this is caused by bz1904379, but I don't know for sure.



For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01865269-python-texext/

For all our attempts to build python-texext with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-texext/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-01-09 10:56:36 UTC

*** This bug has been marked as a duplicate of bug 1904379 ***


Note You need to log in before you can comment on or make changes to this bug.