Bug 1914347 - python-webassets fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats (from python-scss)
Summary: python-webassets fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLE...
Keywords:
Status: CLOSED DUPLICATE of bug 1899555
Alias: None
Product: Fedora
Classification: Fedora
Component: python-scss
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-08 15:57 UTC by Miro Hrončok
Modified: 2021-01-09 10:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-09 01:18:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-01-08 15:57:35 UTC
python-webassets fails to build with Python 3.10.0a4.

=================================== FAILURES ===================================
_______________________________ TestPyScss.test ________________________________

self = <scss.compiler.Compilation object at 0x7f688917b070>
rule = <SassRule <RuleAncestry ()>, 0 props>, scope = None

    def manage_children(self, rule, scope):
        try:
>           self._manage_children_impl(rule, scope)

/usr/lib64/python3.10/site-packages/scss/compiler.py:349: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

self = <scss.compiler.Compilation object at 0x7f688917b070>
rule = <SassRule <RuleAncestry ()>, 0 props>, scope = None

    def _manage_children_impl(self, rule, scope):
        calculator = self._make_calculator(rule.namespace)
    
>       for c_lineno, c_property, c_codestr in locate_blocks(rule.unparsed_contents):
E       SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats

/usr/lib64/python3.10/site-packages/scss/compiler.py:359: SystemError

During handling of the above exception, another exception occurred:

self = <tests.test_filters.TestPyScss object at 0x7f688931d280>

    def test(self):
>       self.mkbundle('foo.scss', filters='pyscss', output='out.css').build()


The error comes from python-scss:

https://docs.python.org/3.10/whatsnew/3.10.html

The PY_SSIZE_T_CLEAN macro must now be defined to use PyArg_ParseTuple() and Py_BuildValue() formats which use #: es#, et#, s#, u#, y#, z#, U# and Z#. See Parsing arguments and building values and the PEP 353. (Contributed by Victor Stinner in https://bugs.python.org/issue40943.)


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01865285-python-webassets/

For all our attempts to build python-webassets with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-webassets/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Dan Callaghan 2021-01-09 01:18:26 UTC
This was already found once before and reported against webassets and moved to pyscss :-)

*** This bug has been marked as a duplicate of bug 1899555 ***

Comment 2 Miro Hrončok 2021-01-09 10:32:11 UTC
> This was already found once before and reported against webassets and moved to pyscss :-)

Sorry about that. Our tracking of bugs reported in different packages is manual and this one was missing in the list.


Note You need to log in before you can comment on or make changes to this bug.