Bug 191440 - parser errors reported by yum cron job
parser errors reported by yum cron job
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 19:08 EDT by Donald Cohen
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:36:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2006-05-11 19:08:33 EDT
Description of problem:
I frequently get output (mail) from the yum cron job with complaints
similar to these (just a sample):

//var/cache/yum/base/repomd.xml:26: parser error : Opening and ending tag misma\
tch: img line 26 and td 
es/standard/images/pm-topright.gif' width='10' alt='' height='8' border='0'></t\
d 
                                                                               \
^ 
//var/cache/yum/base/repomd.xml:27: parser error : Opening and ending tag misma\
tch: td line 26 and tr 
  </tr> 
       ^ 
//var/cache/yum/base/repomd.xml:29: parser error : Opening and ending tag misma\
tch: img line 29 and td 
/themes/standard/images/spacer.gif' alt='' width='6' height='60' border='0'></t\
d 

I suppose this is not a bug in yum itself, but rather in the data it reads. 
Never the less, I hope there's something to be done about it.  This happens
with high frequency and affects (I gather) many machines.
      
Version-Release number of selected component (if applicable):
yum.noarch                               2.4.1-1.fc4            installed 

How reproducible:
Turn on automatic update and wait.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
seem examples above

Expected results:
no complaints similar to those above

Additional info:
Comment 1 Jeremy Katz 2006-09-18 16:36:35 EDT
This is that your machine is pointing to a mirror which doesn't actually have
bits.  We've made some improvements to the mirror infrastructure to help avoid
problems like this

Note You need to log in before you can comment on or make changes to this bug.