Bug 191441 - forcedeth quirks not present in rawhide
Summary: forcedeth quirks not present in rawhide
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-11 23:20 UTC by Aaron Richton
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 01:01:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 156688 None None None Never

Description Aaron Richton 2006-05-11 23:20:32 UTC
Description of problem:
forcedeth driver needs quirks on Many Allegedly Important (To Red Hat) Platforms such as HP 
xw9300 and Sun X2100 (my current nemesis). See bug #156688; comment 8 recommends 
opening bug against FC5. Note that the relevant patches are in 2.6.9-34.EL. 156688 suggests that 
upstream's suggestion is likely to be "fix the HW"; if this is possible, I'd love to work with 
these hardware partners and hear how.

Version-Release number of selected component (if applicable):
2.6.16-1.2200_FC6 (and FC5, and FC5 updates)

How reproducible:
always

Steps to Reproduce:
1. Install Fedora
2. Get upset over lack of ethernet interfaces
3. Run lspci and be amazed at "bridge" notation.
  
Actual results:
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)

Expected results:
an ethernet interface!

Additional info:
I built a local 2.6.16-1.2200_FC6 package with forcedeth patch from 2.6.9-34.EL and life was 
slightly better. The interface barely worked, but at least it came up. One step at a time...

By the time you fix this, I might not have an X2100, because it's only an eval and this is leaving a 
nasty taste. (I hear the Sun X4100 is all tg3.)


Note You need to log in before you can comment on or make changes to this bug.