Bug 19146 - Authentication failed even with correct password
Summary: Authentication failed even with correct password
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: vnc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-15 20:36 UTC by Tim Waugh
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-15 20:37:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's a patch that fixes the problem for me. (1.04 KB, patch)
2000-10-15 20:37 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2000-10-15 20:36:35 UTC
When running vncviewer from an icon on the desktop, sometimes
authentication is refused even though the correct password is entered into
the dialog box.

This seems to be because of constructs such as this:

password = XtNewString(XawDialogGetValueString(dialog));

XawDialogGetValueString frees and reallocates a value to return each time,
and XtNewString is a macro which uses its argument many times, and so if
XawDialogGVS returns a different value on successful calls during the
execution of the expansion of the XtNewString macro, "odd" things happen,
and password ends up pointing to the wrong place.

Comment 1 Tim Waugh 2000-10-15 20:37:49 UTC
Created attachment 4172 [details]
Here's a patch that fixes the problem for me.

Comment 2 Bernhard Rosenkraenzer 2000-10-16 10:08:09 UTC
Thanks, fixed. (Btw: Why don't you just take the vnc package? You're doing much more with it than I am.)

Comment 3 Tim Waugh 2000-10-16 10:14:27 UTC
Ahem.. I thought I had..

Comment 4 Tim Waugh 2000-10-16 10:23:52 UTC
Incidentally, for those that want to check that it really does fix the problem
for them, the fixed package is vnc-3.3.3r1-10.


Note You need to log in before you can comment on or make changes to this bug.