Bug 191461 - DHCP client drops fudge line from /etc/ntp.conf
Summary: DHCP client drops fudge line from /etc/ntp.conf
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-12 08:03 UTC by Kazutoshi Morioka
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 16:57:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix /sbin/dhclient-script (1.03 KB, text/x-patch)
2006-05-12 08:03 UTC, Kazutoshi Morioka
no flags Details

Description Kazutoshi Morioka 2006-05-12 08:03:21 UTC
Description of problem:
DHCP client sets NTP servers if DHCP server has NTP server infomations.
In this case, /sbin/dhclient-script remove server lines from /etc/ntp.conf,
and add NTP servers from DHCP server, and copy "server 127.127.1.0" line from
pre-DHCP /etc/ntp.conf.
But /sbin/dhclient-script dosen't copy "fudge 127.127.1.0" line.
Without fudge line, ntpd treat local system clock with greater stratum
than expected.
This may cause confusion, and get ntpd to take longer time to synchronization.

Version-Release number of selected component (if applicable):
all versions of Fedora ntp package.

How reproducible:
always

Steps to Reproduce:
1. setup DHCP server
2. add "option ntp-servers" line to /etc/dhcpd.conf
3. start dhcp server
4. boot DHCP client with default NTP configuration.
  
Actual results:
/etc/ntp.conf has these server lines
server ntp0.example.com
server ntp1.example.com
server 127.127.1.0

Expected results:
server ntp0.example.com
server ntp1.example.com
server 127.127.1.0
fudge  127.127.1.0 stratum 10

or, without meaningless local system clock
server ntp0.example.com
server ntp1.example.com

Additional info:
Because ntpd runs before firstboot, choosing "no local time source" in
NTP configuration is not in effect.

Comment 1 Kazutoshi Morioka 2006-05-12 08:03:21 UTC
Created attachment 128929 [details]
patch to fix /sbin/dhclient-script

Comment 2 Jason Vas Dias 2006-06-08 22:00:26 UTC
Thanks - now fixed with dhcp-3.0.4-14 (FC-6) and dhcp-3.0.3-28 (FC5).



Note You need to log in before you can comment on or make changes to this bug.