Bug 1914716 - [abrt] fontconfig: FcCacheFini(): fc-cat killed by SIGABRT
Summary: [abrt] fontconfig: FcCacheFini(): fc-cat killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:faec9fe44463ade141d78d21ed9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-11 01:34 UTC by Andrei Coada
Modified: 2022-03-18 19:12 UTC (History)
9 users (show)

Fixed In Version: fontconfig-2.13.94-5.fc35 fontconfig-2.13.94-5.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-05 18:30:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Andrei Coada 2021-01-11 01:34:55 UTC
Description of problem:
Execute 'fc-cat' on terminal.

Version-Release number of selected component:
fontconfig-2.13.92-12.fc33

Additional info:
reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-org.gnome.Terminal.slice/vte-spawn-fc0c512a-c1b3-4b50-b292-10734f6ffb66.scope
cmdline:        fc-cat
crash_function: FcCacheFini
executable:     /usr/bin/fc-cat
journald_cursor: s=edb01db202524c8a9c351612f950351c;i=13f1dd;b=581905cc456c4883a3a415bed8454698;m=3fe0674da;t=5b895ccfd6276;x=42d0dcbb4cc5e360
kernel:         5.9.16-200.fc33.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #4 FcCacheFini at fccache.c:807
 #5 IA__FcFini at fcinit.c:205

Comment 11 Akira TAGOH 2021-01-26 08:40:25 UTC
This should be improved in rawhide but I have no plans to backport this change to f33 or before so far because that contains a lot of changes and that is a little complicated to cherry-pick.

Comment 12 Andrei Coada 2021-01-26 12:20:00 UTC
Alright. Thanks Akira.

Comment 13 Ian Pilcher 2021-06-18 22:56:57 UTC
Seems to still be broken in F34.  I'm getting:

fc-cat: fccache.c:807: FcCacheFini: Assertion `fcCacheChains[i] == NULL' failed.

Program received signal SIGABRT, Aborted.

I really need to figure out some font-related issued after upgrading to F34, so any hints on getting a working version would be appreciated.

Comment 14 Akira TAGOH 2021-06-21 04:51:53 UTC
How did you get that abort? is it reproducible?

Comment 15 Ian Pilcher 2021-06-21 23:09:19 UTC
(In reply to Akira TAGOH from comment #14)
> How did you get that abort? is it reproducible?

I just typed 'fc-cat' in a Konsole window.

It's 100% reproducible on my system; happens every time.

Comment 16 Akira TAGOH 2021-06-22 07:44:31 UTC
Thanks. I can reproduce it here too.

Comment 17 Fedora Update System 2022-03-03 09:43:47 UTC
FEDORA-2022-b00e17ca83 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b00e17ca83

Comment 18 Fedora Update System 2022-03-03 09:44:58 UTC
FEDORA-2022-1b9895f2c2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-1b9895f2c2

Comment 19 Fedora Update System 2022-03-03 16:39:59 UTC
FEDORA-2022-b00e17ca83 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b00e17ca83`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b00e17ca83

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-03-03 16:45:37 UTC
FEDORA-2022-1b9895f2c2 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-1b9895f2c2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-1b9895f2c2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-03-05 18:30:45 UTC
FEDORA-2022-b00e17ca83 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2022-03-18 19:12:19 UTC
FEDORA-2022-1b9895f2c2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.