Bug 1914751 - After upgrade default_download_policy changed from "on_demand" to "immediate"
Summary: After upgrade default_download_policy changed from "on_demand" to "immediate"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.9.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: 6.9.0
Assignee: satellite6-bugs
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-11 06:34 UTC by Devendra Singh
Modified: 2021-02-16 17:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
After upgrading Satellite from version 6.8 to 6.9, the default_download_policy changed from *on_demand* to *immediate*.
Clone Of:
Environment:
Last Closed: 2021-02-16 17:33:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Devendra Singh 2021-01-11 06:34:36 UTC
Description of problem: After upgrade default_download_policy changed from "on_demand" to "immediate"


Version-Release number of selected component (if applicable):
6.9 Snap7

How reproducible:
always

Steps to Reproduce:
1. Install the 6.8 base version.
2. Check the default_download_policy value before the upgrade.
3. the set value is "on_demand"
4. Upgrade the satellite from 6.8 to 6.9.
5. default_download_policy value changed from "on_demand" to "immediate"

Actual results:
default_download_policy value changed after upgrade.

Expected results:
default_download_policy value should remain the same after upgrade.

Additional info:

Comment 1 Justin Sherrill 2021-01-15 00:20:45 UTC
the default on new installs changed as part of https://bugzilla.redhat.com/show_bug.cgi?id=1732056  in 6.7, its strange that its being reset upon upgrade to 6.9.  we will investigate

Comment 3 Justin Sherrill 2021-02-15 18:32:50 UTC
I'm not able to reproduce this.  I installed Satellite 6.8, changed default_download_policy to 'on_demand' (from immediate).  Then upgraded to 6.9 and examined the administer > settings > content page. 

Are you able to reproduce on the latest snap?

Comment 4 Justin Sherrill 2021-02-15 18:33:18 UTC
If you can reproduce, being pointed to a reproducer server might be helpful

Comment 6 Justin Sherrill 2021-02-16 17:33:48 UTC
After talking with Devendra, we discovered that the satellite in question had been upgraded from 6.6.  The default download policy was updated from 'on_demand' to 'immediate' as part of 6.7, but it appears that the default value wasn't actually updated in the db at that time.  This is likely due to a bug in the settings related code.  It seems that this bug was fixed as part of 6.9 though, and thus the default value was updated resulting in a change in behavior.  

Here's the 6.7 bz that changed it:  https://bugzilla.redhat.com/show_bug.cgi?id=1732056  and it includes appropriate docs text.  So in reality this was a 6.7/6.8 bug in settings as the change was expected at that time.  As a result we're going to close this bz


Note You need to log in before you can comment on or make changes to this bug.