Bug 1914830 - python-metakernel: FTBFS in Fedora rawhide
Summary: python-metakernel: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-metakernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-11 10:03 UTC by Tomáš Hrnčiar
Modified: 2021-01-17 09:37 UTC (History)
1 user (show)

Fixed In Version: python-metakernel-0.27.5-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-17 09:37:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-11 10:03:25 UTC
Description of problem:
Package python-metakernel fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.27.5-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-metakernel-0.27.5-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-metakernel

=================================== FAILURES ===================================
_________________________ REPLWrapTestCase.test_python _________________________
self = <metakernel.tests.test_replwrap.REPLWrapTestCase testMethod=test_python>
    def test_python(self):
        if platform.python_implementation() == 'PyPy':
            raise unittest.SkipTest("This test fails on PyPy because of REPL differences")
    
        p = replwrap.python(sys.executable)
        res = p.run_command('4+7')
>       assert res.strip() == '11'
E       AssertionError: assert '\x1b[?2004l\...\n\x1b[?2004h' == '11'
E         - 11
E         + [?2004l
E         + 11
E         + [?2004h
/builddir/build/BUILD/metakernel-0.27.5/metakernel/tests/test_replwrap.py:81: AssertionError
=============================== warnings summary ===============================
/usr/lib/python3.9/site-packages/ipykernel/iostream.py:14
  /usr/lib/python3.9/site-packages/ipykernel/iostream.py:14: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
    from imp import lock_held as import_lock_held
-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
FAILED metakernel/tests/test_replwrap.py::REPLWrapTestCase::test_python - Ass...
============= 1 failed, 77 passed, 3 skipped, 1 warning in 45.29s ==============

Comment 1 Mattias Ellert 2021-01-17 09:37:28 UTC
One of the tests started failing when the readline library was updated from version 8.0 to 8.1.
The failure has been reported upstream: https://github.com/Calysto/metakernel/issues/228
The failing test was disabled in the package build.


Note You need to log in before you can comment on or make changes to this bug.