Bug 1914873 - python-registry: FTBFS in Fedora rawhide - explicitly BuildRequire python-six
Summary: python-registry: FTBFS in Fedora rawhide - explicitly BuildRequire python-six
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-registry
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-11 11:54 UTC by Tomáš Hrnčiar
Modified: 2021-02-02 03:09 UTC (History)
1 user (show)

Fixed In Version: python-registry-1.4-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-02 03:09:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-11 11:54:27 UTC
Description of problem:
Package python-registry fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.3.1-4.fc33

Steps to Reproduce:
koji build --scratch f34 python-registry-1.3.1-4.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-registry

==================================== ERRORS ====================================
______________ ERROR collecting tests/test_reorganized_values.py _______________
ImportError while importing test module '/builddir/build/BUILD/python-registry-1.3.1/tests/test_reorganized_values.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_reorganized_values.py:4: in <module>
    import six
E   ModuleNotFoundError: No module named 'six'
_________________ ERROR collecting tests/test_unicode_names.py _________________
ImportError while importing test module '/builddir/build/BUILD/python-registry-1.3.1/tests/test_unicode_names.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_unicode_names.py:4: in <module>
    import six
E   ModuleNotFoundError: No module named 'six'
=========================== short test summary info ============================
ERROR tests/test_reorganized_values.py
ERROR tests/test_unicode_names.py
!!!!!!!!!!!!!!!!!!! Interrupted: 2 errors during collection !!!!!!!!!!!!!!!!!!!!
============================== 2 errors in 0.12s ===============================

This looks like missing BuildRequire for python-six.

Comment 1 Fedora Release Engineering 2021-01-24 04:22:50 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-08).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Fedora Update System 2021-01-24 10:15:48 UTC
FEDORA-2021-26b42f58a2 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-26b42f58a2

Comment 3 Fedora Update System 2021-01-25 02:18:52 UTC
FEDORA-2021-26b42f58a2 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-26b42f58a2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-26b42f58a2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-02-02 03:09:37 UTC
FEDORA-2021-26b42f58a2 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.