Bug 1914874 - hexchat fails to load python plugin (missing dep on python3-cffi)
Summary: hexchat fails to load python plugin (missing dep on python3-cffi)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hexchat
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Patrick Griffis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-11 11:54 UTC by Andrea Perotti
Modified: 2021-01-17 01:50 UTC (History)
5 users (show)

Fixed In Version: hexchat-2.14.3-8.fc34 hexchat-2.14.3-9.fc34 hexchat-2.14.3-8.eln108 hexchat-2.14.3-9.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 22:19:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrea Perotti 2021-01-11 11:54:51 UTC
Description of problem:

After upgrading to Fedora33, hexchat fails to load the python plugin.

This is caused by the lack of python3-cffi package.


Version-Release number of selected component (if applicable):

hexchat-2.14.3-7.fc33.x86_64

How reproducible:

always

Steps to Reproduce:
1. Upgrade to Fedora 33
2. run hexchat
3. 

Actual results:

Python plugin is not loaded, so no python script works.

If you run hexchat from cli can be seen the error:

$ hexchat 
Failed to initialize the Python-CFFI embedding logic:

Traceback (most recent call last):
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 984, in _find_and_load_unlocked
ModuleNotFoundError: No module named '_cffi_backend'

From: _hexchat_embedded
compiled with cffi version: 1.14.1
_cffi_backend module: not loaded
sys.path: ['/usr/lib64/python39.zip', '/usr/lib64/python3.9', '/usr/lib64/python3.9/lib-dynload', '/usr/lib64/python3.9/site-packages', '/usr/lib/python3.9/site-packages']

function _hexchat_embedded._on_plugin_init() called, but initialization code failed.  Returning 0.


Expected results:

Loading python plugin as well.

If you install python3-cffi it works.

Checking last commit:
https://src.fedoraproject.org/rpms/hexchat/c/0803858a956c090d40f98998e9d1057d7fd040f5?branch=master

probably python3-cffi should not be only a BuildRequires but an explicit dependency.

Comment 1 Kevin Fenzi 2021-01-15 20:42:45 UTC
Indeed. Sorry about that, I thought it would get picked up automatically. ;( 

Update on the way...

Comment 2 Fedora Update System 2021-01-15 20:57:10 UTC
FEDORA-2021-ad7a37d9a1 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ad7a37d9a1

Comment 3 Brian Morrison 2021-01-15 21:31:47 UTC
This won't install because the spec file contains:

Requires: python3-cff1

instead of

Requires: python3-cffi

I rebuilt it locally with this change and it upgrades just fine.

Comment 4 Kevin Fenzi 2021-01-15 21:47:32 UTC
yes, I already noticed and fired new builds. Sorry for the typo.

Comment 5 Brian Morrison 2021-01-15 21:52:56 UTC
Cheers Kevin, all good now.

Comment 6 Fedora Update System 2021-01-15 22:19:02 UTC
FEDORA-2021-b753665428 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2021-01-15 22:22:06 UTC
FEDORA-2021-ddea1a3088 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-01-15 22:28:01 UTC
FEDORA-2021-c205a69745 has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-01-16 02:18:22 UTC
FEDORA-2021-c0c9f907f4 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c0c9f907f4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c0c9f907f4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-01-17 01:50:15 UTC
FEDORA-2021-c0c9f907f4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.