Bug 1915334 - python-autobahn: FTBFS in Fedora rawhide: pytest.ini: 'minversion' requires pytest-6.2, actual pytest-6.0.2'
Summary: python-autobahn: FTBFS in Fedora rawhide: pytest.ini: 'minversion' requires p...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-autobahn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Julien Enselme
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-12 13:13 UTC by Tomáš Hrnčiar
Modified: 2021-01-12 15:51 UTC (History)
3 users (show)

Fixed In Version: python-autobahn-20.12.3-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-12 15:51:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-12 13:13:15 UTC
Description of problem:
Package python-autobahn fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
20.12.2-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-autobahn-20.12.2-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-autobahn

ERROR: /builddir/build/BUILD/autobahn-python-20.12.3/pytest.ini: 'minversion' requires pytest-6.2, actual pytest-6.0.2'

pytest in Fedora wasn't yet updated to v.6.2.0 because it brings in too many breaking changes.

Comment 1 Miro Hrončok 2021-01-12 13:51:28 UTC
Note that we won't update pytest to 6.2 any time soon, so a revert might be needed here.


Note You need to log in before you can comment on or make changes to this bug.