Bug 191538 - Review Request: qsynth - Qt based Fluidsynth GUI front end
Review Request: qsynth - Qt based Fluidsynth GUI front end
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Package Reviews List
:
Depends On: 189886
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-05-12 15:33 EDT by Fernando Lopez-Lezcano
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 15:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fernando Lopez-Lezcano 2006-05-12 15:33:40 EDT
Spec URL: http://ccrma.stanford.edu/planetccrma/extras/qsynth.spec
SRPM URL: http://ccrma.stanford.edu/planetccrma/extras/qsynth-0.2.5-2.src.rpm
Description: QSynth is a fluidsynth GUI front-end application written in C++ around
the Qt3 toolkit using Qt Designer. Eventually it may evolve into a
softsynth management application allowing the user to control and
manage a variety of command line softsynth but for the moment it wraps
the excellent FluidSynth. FluidSynth is a command line software
synthesiser based on the Soundfont specification.

An excellent GUI wrapper for the fluidsynth software synth. Requires fluidsynth and indirectly jack-audio-connection-kit, both of which are still waiting for approval. See:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189886
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183912

[second package submission, I think I still need a sponsor]
Comment 1 Anthony Green 2006-06-08 13:20:48 EDT
Hi Fernando.  Here are some comments.  Some of these may seem nit-picky - sorry
about that...

* Release should use %{?dist}

* Alignment is inconsistent with rest of Fedora, so..
Summary: Qt based Fluidsynth GUI front end
Name: qsynth
Version: 0.2.5
..should be...
Summary: Qt based Fluidsynth GUI front end
Name:    qsynth
Version: 0.2.5

* Some people prefer that we use %makeinstall, although I don't know if it's 
required.  I've been using it in all my spec files based on somebody's request.

* Don't install the generic INSTALL file.

* Remember to put version info for each changelog entry 
rpmlint ../RPMS/i386/qsynth-0.2.5-2.i386.rpm
W: qsynth no-version-in-last-changelog

* I believe you should use the following before %configure...
unset QTDIR || : ; . /etc/profile.d/qt.sh
export QTLIB=${QTDIR}/lib QTINC=${QTDIR}/include

That's it for now.  Thanks!
Comment 2 Anthony Green 2006-06-08 13:28:02 EDT
One more thing.. I tried this with VintageDreams soundfont, and found that I had
to turn the gain down to 10 or less in order to stop the output from red-lining.
 The gain setting defaults to 100.  Is this expected?
Comment 3 Hans de Goede 2006-06-15 06:03:01 EDT
I'm reviewing fluidsynth now so that this one can get some progress too.
Comment 4 Hans de Goede 2006-06-15 08:18:07 EDT
MUST:
=====
* rpmlint output is:
W: qsynth no-version-in-last-changelog
W: qsynth-debuginfo no-version-in-last-changelog
These both must be fixed.
* Package and spec file named appropriately
* Packaged according to packaging guidelines
* License (GPL) ok, license file included
* spec file is legible and in Am. English.
* Source matches upstream
* Compiles and builds on devel-i386
* BR: ok
* No locales
* No shared libraries
* Not relocatable
* Package owns / or requires all dirs
* No duplicate files & Permissions ok
* %clean & macro usage OK
* Contains code only
* %doc does not affect runtime, and isn't large enough to warrent a sub package
* no -devel package needed, no libs / .la files.
* .desktop file as required and properly installed

MUST fix:
=========
* rpmlint output is:
W: qsynth no-version-in-last-changelog
W: qsynth-debuginfo no-version-in-last-changelog
These both must be fixed.
* Source0: http://dl.sf.net/qsynth/qsynth-%{version}.tar.gz
 Must be: Source0: http://dl.sf.net/sourceforge/qsynth/qsynth-%{version}.tar.gz
* %makeinstall is broken (yeah I know, someone should fix it) please use:
  make install DESTDIR=$RPM_BUILD_ROOT instead. (Or make that %{__make} ......)
* Under %files I see %{_datadir}/icons/qsynth.png, that is not according to the
  freedesktop.org icon standard, it should go under:
  %{_datadir}/icons/hicolor/32x32/apps
  Where 32x32 is the size of the icon, please do ls /usr/share/icons/hicolor/
  to see the available valid sizes, if the icon doesn't match any pick the 
  closest.
* Once the icon is in the proper case you must add %post(un) script to update 
  the icon-cache see:
http://fedoraproject.org/wiki/ScriptletSnippets#head-fc74f078205565f961f6d836b77c3428619c689d
Comment 5 Fernando Lopez-Lezcano 2006-06-18 22:22:57 EDT
(In reply to comment #4)
> * rpmlint output is:
> W: qsynth no-version-in-last-changelog
> W: qsynth-debuginfo no-version-in-last-changelog
> These both must be fixed.
> * Source0: http://dl.sf.net/qsynth/qsynth-%{version}.tar.gz
>  Must be: Source0: http://dl.sf.net/sourceforge/qsynth/qsynth-%{version}.tar.gz
> * %makeinstall is broken (yeah I know, someone should fix it) please use:
>   make install DESTDIR=$RPM_BUILD_ROOT instead. (Or make that %{__make} ......)
> * Under %files I see %{_datadir}/icons/qsynth.png, that is not according to the
>   freedesktop.org icon standard, it should go under:
>   %{_datadir}/icons/hicolor/32x32/apps
>   Where 32x32 is the size of the icon, please do ls /usr/share/icons/hicolor/
>   to see the available valid sizes, if the icon doesn't match any pick the 
>   closest.
> * Once the icon is in the proper case you must add %post(un) script to update 
>   the icon-cache see:
>
http://fedoraproject.org/wiki/ScriptletSnippets#head-fc74f078205565f961f6d836b77c3428619c689d

All fixed:
Spec URL: http://ccrma.stanford.edu/planetccrma/extras/qsynth.spec
SRPM URL: http://ccrma.stanford.edu/planetccrma/extras/qsynth-0.2.5-4.src.rpm
Comment 6 Hans de Goede 2006-06-20 14:22:09 EDT
Looks good, approved and so does qjackctl, concider yourself sponsored.

Please create an account (or add yourself to the cvsextras group if you alreayd
have). This and the next steps are described here:
http://fedoraproject.org/wiki/Extras/Contributors .

Notice that I'm keeping the blocker bug as FE-REVIEW for now and that you
shouldn't import this yet as not all deps (fluidsynth) have been imported and
build. I've done a full review of the deps, but unfortunatly no response sofar.
Comment 7 Hans de Goede 2006-06-23 08:14:11 EDT
Erm.

Is it me or haven't you created an Fedora account yet. As far as I'm concerned
your good to go to create a Fedora account and then I'll sponsor you. After
which you can imprt qjackctl, this one will has to wait until al the deps are done.
Comment 8 Fernando Lopez-Lezcano 2006-06-23 18:48:09 EDT
(In reply to comment #7)
> Erm.
> 
> Is it me or haven't you created an Fedora account yet. As far as I'm concerned
> your good to go to create a Fedora account and then I'll sponsor you. 

Sorry, no, it is not you, I have had a very busy week... I'll get to it as soon
as I can find a minute. I really appreciate your sponsorship. 
Comment 9 Hans de Goede 2006-06-24 00:46:15 EDT
(In reply to comment #8)
> Sorry, no, it is not you, I have had a very busy week... I'll get to it as soon
> as I can find a minute. I really appreciate your sponsorship. 
> 

No problem we all have those sometimes (busy weeks).
Comment 10 Hans de Goede 2006-08-02 09:14:34 EDT
Oops, I forgot to set this to FE-ACCEPT, doing so now.

Note You need to log in before you can comment on or make changes to this bug.