Bug 1915671 - undefined method `request'
Summary: undefined method `request'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vagrant
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1942959 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-13 08:14 UTC by Petr Lautrbach
Modified: 2021-05-19 01:21 UTC (History)
7 users (show)

Fixed In Version: vagrant-2.2.9-5.fc34 vagrant-2.2.16-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-19 01:21:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Lautrbach 2021-01-13 08:14:33 UTC
Description of problem:

$ vagrant up
/usr/share/rubygems/rubygems/resolver/conflict.rb:47:in `conflicting_dependencies': undefined method `request' for nil:NilClass (NoMethodError)
        from /usr/share/rubygems/rubygems/exceptions.rb:32:in `conflicting_dependencies'
        from /usr/share/rubygems/rubygems/exceptions.rb:26:in `initialize'
        from /usr/share/rubygems/rubygems/resolver.rb:193:in `exception'
        from /usr/share/rubygems/rubygems/resolver.rb:193:in `raise'
        from /usr/share/rubygems/rubygems/resolver.rb:193:in `rescue in resolve'
        from /usr/share/rubygems/rubygems/resolver.rb:191:in `resolve'
        from /usr/share/rubygems/rubygems/request_set.rb:411:in `resolve'
        from /usr/share/rubygems/rubygems/request_set.rb:423:in `resolve_current'
        from /usr/share/rubygems/rubygems.rb:240:in `finish_resolve'
        from /usr/share/rubygems/rubygems.rb:303:in `block in activate_bin_path'
        from /usr/share/rubygems/rubygems.rb:301:in `synchronize'
        from /usr/share/rubygems/rubygems.rb:301:in `activate_bin_path'
        from /usr/share/vagrant/gems/bin/vagrant:23:in `<main>'
/usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:317:in `raise_error_unless_state': Unable to satisfy the following requirements: (Gem::Resolver::Molinillo::VersionConflict)

- `vagrant (= 2.2.9)` required by `user-specified dependency`
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:299:in `block in unwind_for_conflict'
        from <internal:kernel>:90:in `tap'
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:297:in `unwind_for_conflict'
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:678:in `attempt_to_activate'
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:254:in `process_topmost_state'
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:182:in `resolve'
        from /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolver.rb:43:in `resolve'
        from /usr/share/rubygems/rubygems/resolver.rb:190:in `resolve'
        from /usr/share/rubygems/rubygems/request_set.rb:411:in `resolve'
        from /usr/share/rubygems/rubygems/request_set.rb:423:in `resolve_current'
        from /usr/share/rubygems/rubygems.rb:240:in `finish_resolve'
        from /usr/share/rubygems/rubygems.rb:303:in `block in activate_bin_path'
        from /usr/share/rubygems/rubygems.rb:301:in `synchronize'
        from /usr/share/rubygems/rubygems.rb:301:in `activate_bin_path'
        from /usr/share/vagrant/gems/bin/vagrant:23:in `<main>'



$ rpm -qf /usr/share/rubygems/rubygems/resolver/molinillo/lib/molinillo/resolution.rb                   
rubygems-3.2.3-142.fc34.noarch


$ rpm -q vagrant                                                                     
vagrant-2.2.9-4.fc34.noarch

Comment 1 Vít Ondruch 2021-01-13 08:33:37 UTC
Yes, this is unfortunately broken by update to Ruby 3.0 [1]. Not sure if it was feasible for you to temporary downgrade, because Vagrant has quite some dependencies. I have to take a look what I can do about it. No ETA ATM, sorry.

[1] https://koschei.fedoraproject.org/package/vagrant

Comment 2 Fedora Update System 2021-01-21 11:13:54 UTC
FEDORA-2021-ae6270b713 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 3 Petr Lautrbach 2021-01-25 07:59:57 UTC
$ vagrant up --provision  
Bringing machine 'default' up with 'libvirt' provider...
<internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- rexml/document (LoadError)
        from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from /usr/share/vagrant/gems/gems/vagrant-libvirt-0.1.2/lib/vagrant-libvirt/action/start_domain.rb:2:in `<top (required)>'
        from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from /usr/share/vagrant/gems/gems/vagrant-libvirt-0.1.2/lib/vagrant-libvirt/action.rb:50:in `block (2 levels) in action_up'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/call.rb:47:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/box_check_outdated.rb:36:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-sshfs-1.3.5/lib/vagrant-sshfs/action_hostpath_fixup.rb:125:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/config_validate.rb:25:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-sshfs-1.3.5/lib/vagrant-sshfs/action_hostpath_fixup.rb:102:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builder.rb:149:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/runner.rb:89:in `block in run'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/util/busy.rb:19:in `busy'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/runner.rb:89:in `run'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:240:in `action_raw'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:212:in `block in action'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/environment.rb:613:in `lock'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:198:in `call'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:198:in `action'
        from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/batch_action.rb:86:in `block (2 levels) in run'

$ rpm -qf /usr/share/rubygems/rubygems/core_ext/kernel_require.rb                
rubygems-3.2.3-144.fc34.noarch

$ rpm -q vagrant                                                 
vagrant-2.2.9-5.fc34.noarch

New bug? My local problem?

Comment 4 Vít Ondruch 2021-01-25 08:37:58 UTC
(In reply to Petr Lautrbach from comment #3)
> New bug? My local problem?

There is probably missing REXML dependency, which was removed from default Ruby installation. As a workaround, `dnf install rubygem-rexml` should help and I'll look into details.

Comment 5 Petr Lautrbach 2021-01-25 10:08:51 UTC
(In reply to Vít Ondruch from comment #4)
> (In reply to Petr Lautrbach from comment #3)
> > New bug? My local problem?
> 
> There is probably missing REXML dependency, which was removed from default
> Ruby installation. As a workaround, `dnf install rubygem-rexml` should help
> and I'll look into details.

Works, thanks!

Comment 6 Ben Cotton 2021-02-09 16:13:15 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 7 Vít Ondruch 2021-03-25 12:44:38 UTC
*** Bug 1942959 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2021-05-17 13:44:10 UTC
FEDORA-2021-17ded5c4ca has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-17ded5c4ca

Comment 9 Fedora Update System 2021-05-17 13:44:17 UTC
FEDORA-2021-17ded5c4ca has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-17ded5c4ca

Comment 10 Fedora Update System 2021-05-18 01:57:32 UTC
FEDORA-2021-17ded5c4ca has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-17ded5c4ca`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-17ded5c4ca

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-05-19 01:21:54 UTC
FEDORA-2021-17ded5c4ca has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.