Bug 191595 - guile-devel deps missing
guile-devel deps missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-13 14:03 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 08:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove hard-coded -lltdl from guile-config (414 bytes, patch)
2006-05-18 07:38 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-05-13 14:03:29 EDT
apps that use libtool building against current devel's guile-devel will fail
linking with error:
/usr/bin/ld: cannot find -lltdl

This is due to guile-devel's inclusion of libguile.la containing a reference to
-lltdl

Possible fixes:
1.  (preferred) Follow Packaging Guidelines recommendation to omit/remove
%{_libdir}/lib*.la files from packaging  (while you're at it, you can omit
static libs as well, provided no other pkg in Core uses libguile.a).
2.  Add to -devel
Requires: libtool-ltdl-devel
Comment 1 Miroslav Lichvar 2006-05-16 09:35:47 EDT
Ok, thanks. Fixed in guile-1.8.0-3.
Comment 2 Eric Tanguy 2006-05-18 02:00:16 EDT
I tried building drgeo from extras in mock devel as guile-1.8.0-3 is out and the
building still fails with the same error : 
g++ -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -o drgeo drgenius_main.o drgenius_mdi.o
drgenius_config.o drgeo_adaptDialog.o drgenius_view.o geo_view.o editor_view.o
drgeo_init.o drgeo_printer.o -Wl,--export-dynamic  ./geo/libgeo.a -lglade-2.0
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0
-lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lxml2 -lz
-pthread -lguile -L/usr/lib -lgmp -lm -lltdl -lcrypt
/usr/bin/ld: cannot find -lltdl
Comment 3 Rex Dieter 2006-05-18 07:26:19 EDT
Eric, your problem seems different, as your link stage is explicitly listing
-lltdl for some reason.  Find where the -lltdl is coming from...
Comment 4 Rex Dieter 2006-05-18 07:32:19 EDT
Problem is in guile-config --libs returning: -lguile -lltdl
Comment 5 Rex Dieter 2006-05-18 07:34:11 EDT
Sorry, it's 'guile-config link'.  It's different than most other *-config
scripts I've seen. (:
Comment 6 Rex Dieter 2006-05-18 07:37:36 EDT
Miroslav, it's your call what's easier for you:
1.  apply patch to remove hard-coded -lltdl from guile-config
2.  Add to -devel: Requires: libtool-ltdl-devel

patch forthcoming.
Comment 7 Rex Dieter 2006-05-18 07:38:37 EDT
Created attachment 129411 [details]
remove hard-coded -lltdl from guile-config
Comment 8 Miroslav Lichvar 2006-05-18 08:24:27 EDT
Fixed in guile-1.8.0-4.

Note You need to log in before you can comment on or make changes to this bug.