Bug 1916094 - dnf system-upgrade download failed
Summary: dnf system-upgrade download failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BetaBlocker, F34BetaBlocker 1906086
TreeView+ depends on / blocked
 
Reported: 2021-01-14 08:01 UTC by lnie
Modified: 2021-02-21 18:01 UTC (History)
20 users (show)

Fixed In Version: pipewire-0.3.22-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-21 18:01:21 UTC
Type: Bug


Attachments (Terms of Use)
journal (436.49 KB, text/plain)
2021-01-14 08:01 UTC, lnie
no flags Details

Description lnie 2021-01-14 08:01:40 UTC
Created attachment 1747318 [details]
journal

Description of problem:
[root@hpe-dl360g5-01 lnie]# dnf system-upgrade download --refresh --releasever=34 -y
beaker-harness                                                                                                                                                                                                 59 kB/s | 1.3 kB     00:00    
beaker-tasks                                                                                                                                                                                                  371 kB/s | 1.3 kB     00:00    
Fedora 34 openh264 (From Cisco) - x86_64                                                                                                                                                                      3.4 kB/s | 989  B     00:00    
Fedora Modular 34 - x86_64                                                                                                                                                                                     43 kB/s |  13 kB     00:00    
Fedora Modular 34 - x86_64 - Updates                                                                                                                                                                           42 kB/s |  13 kB     00:00    
^CFedora 34 - x86_64 - Updates                                                                                                                                                                                  0.0  B/s |   0  B     00:00    
Error: Failed to download metadata for repo 'updates': Cannot prepare internal mirrorlist: Interrupted by signal
[root@hpe-dl360g5-01 lnie]# dnf system-upgrade download --refresh --releasever=34 -y
beaker-harness                                                                                                                                                                                                268 kB/s | 1.3 kB     00:00    
beaker-tasks                                                                                                                                                                                                  401 kB/s | 1.3 kB     00:00    
Fedora 34 openh264 (From Cisco) - x86_64                                                                                                                                                                      3.6 kB/s | 989  B     00:00    
Fedora Modular 34 - x86_64                                                                                                                                                                                     43 kB/s |  13 kB     00:00    
Fedora Modular 34 - x86_64 - Updates                                                                                                                                                                           43 kB/s |  13 kB     00:00    
Fedora 34 - x86_64 - Updates                                                                                                                                                                                   44 kB/s |  13 kB     00:00    
Fedora 34 - x86_64                                                                                                                                                                                            582 kB/s | 1.6 MB     00:02    
no group 'arm-tools' from environment 'workstation-product-environment'
No match for group package "xorg-x11-drv-armsoc"
No match for group package "powerpc-utils"
No match for group package "lsvpd"
No match for group package "khmeros-siemreap-fonts"
No match for group package "khmeros-metal-chrieng-fonts"
No match for group package "khmeros-bokor-fonts"
No match for group package "khmeros-battambang-fonts"
No match for group package "bcm283x-firmware"
No match for group package "khmeros-muol-fonts"
No match for group package "khmeros-handwritten-fonts"
Error: 
 Problem: problem with installed package pulseaudio-14.0-2.fc33.x86_64
  - package pulseaudio-14.0-3.fc34.x86_64 conflicts with pulseaudio-daemon provided by pipewire-pulseaudio-0.3.19-4.fc34.x86_64
  - package pipewire-pulseaudio-0.3.19-4.fc34.x86_64 conflicts with pulseaudio provided by pulseaudio-14.0-3.fc34.x86_64
  - package pipewire-pulseaudio-0.3.19-4.fc34.x86_64 conflicts with pulseaudio-daemon provided by pulseaudio-14.0-3.fc34.x86_64
  - conflicting requests
  - pulseaudio-14.0-2.fc33.x86_64 does not belong to a distupgrade repository
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)


Version-Release number of selected component (if applicable):
python3-dnf-plugin-system-upgrade-4.0.13-1.fc33.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2021-01-14 09:54:02 UTC
Only workstation upgrade is affected,server and minimal are fine.

Comment 2 Marek Blaha 2021-01-18 14:00:45 UTC
Re-assigning to pulseaudio for further investigation.

Comment 3 Fedora Blocker Bugs Application 2021-02-02 10:38:48 UTC
Proposed as a Blocker for 34-beta by Fedora user lnie using the blocker tracking app because:

 This affects:
For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed.

Comment 4 Adam Williamson 2021-02-04 23:50:56 UTC
It does work with --allowerasing , as the tool suggests. openQA sees this at first:

https://openqa.fedoraproject.org/tests/768778#step/upgrade_run/15

but then tries with --allowerasing , and it works:

https://openqa.fedoraproject.org/tests/768778#step/upgrade_run/18

...probably by replacing pulseaudio with pipewire.

If we actually intend to replace pulseaudio with pipewire on upgrade, obsoletes/provides should be set so this happens without the need for --allowerasing. If we *don't* intend to do that, deps should be set up such that upgrade can complete and retain pulseaudio without this problem, whatever precisely is triggering it...

Comment 5 Adam Williamson 2021-02-04 23:53:45 UTC
The Change page:
https://fedoraproject.org/wiki/Changes/DefaultPipeWire#Upgrade.2Fcompatibility_impact
suggests the intent is to replace on upgrade, so the fix should be to set appropriate obsoletes/provides for that to happen without --allowerasing being needed.

Comment 6 Ben Cotton 2021-02-12 20:44:10 UTC
Should this bug be moved to the pipewire component?

Comment 7 Adam Williamson 2021-02-12 21:52:23 UTC
Yeah. And f34 since that's where the change will be.

Comment 8 James Szinger 2021-02-12 23:20:48 UTC
The change proposal says, “In the same way, installing the pulseaudio package would remove the pipewire-pulseaudio package, making it possible to switch between implementations. This will also allow for an easy rollback.”  Is this possible if pipewire obsoletes/provides pulseaudio?

Comment 9 Ben Cotton 2021-02-19 18:42:09 UTC
It appears update FEDORA-2021-ae6cbfff6b (and the subsequent update FEDORA-2021-c5f362e608) contain a fix for this. Setting to ON_QA.

Comment 10 Adam Williamson 2021-02-19 19:15:36 UTC
It's not in the most recent compose. openQA results for the next compose should tell us if it's fixed.

Comment 11 Adam Williamson 2021-02-21 18:01:21 UTC
The desktop upgrade tests don't show a soft fail in today's compose, indicating this is fixed.


Note You need to log in before you can comment on or make changes to this bug.