Bug 191611 - subversion fails to build in mock
subversion fails to build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-13 16:31 EDT by Garrick Staples
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.3.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 07:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed mock build log (1.12 MB, text/plain)
2006-05-13 16:31 EDT, Garrick Staples
no flags Details
macro the ruby sitelibdir (397 bytes, text/plain)
2006-05-13 22:30 EDT, Garrick Staples
no flags Details

  None (edit)
Description Garrick Staples 2006-05-13 16:31:06 EDT
Description of problem:
Fails to build in mock with FC-devel-i386 config.  Attaching buildlog.
Comment 1 Garrick Staples 2006-05-13 16:31:06 EDT
Created attachment 128982 [details]
failed mock build log
Comment 2 Garrick Staples 2006-05-13 22:30:35 EDT
Created attachment 128988 [details]
macro the ruby sitelibdir

I haven't been able to test this in mock because rawhide is currently broken,
but I think this patch fixes the issue.
Comment 3 Joe Orton 2006-05-15 03:13:56 EDT
I don't really see the problem, the paths look right, and this isn't failing in
our internal build system; does it fail if the SRPM is rebuilt using "rpm
--rebuild"?
Comment 4 Garrick Staples 2006-05-15 05:35:21 EDT
checking where to install Ruby scripts... /usr/lib/ruby/site_ruby/1.8
checking where to install Ruby extensions... /usr/lib/ruby/site_ruby/1.8/i386-linux

The subversion spec uses %{_libdir}/site_ruby which is the cause of the build
failure.

It builds fine with 'rpm --rebuild' under FC5.  But under mock with devel (FC6),
ruby is installing sitelibs into a different directory.  

The spec patch queries ruby (in the same way as the subversion configure script)
for the correct location ensuring that the correct path is always found.

Maybe this is actually a bug in FC6's ruby?  I don't know.  I don't know
anything about ruby.  But either way, this patch makes the subversion spec
"always correct" and more portable.
Comment 5 Joe Orton 2006-06-02 06:32:19 EDT
The build is still failing on x86_64 in the FC6 buildroot with this patch applied.

The build there says:
 
checking where to install Ruby scripts... /usr/lib/ruby/site_ruby/1.8
checking where to install Ruby extensions...
/usr/lib/ruby/site_ruby/usr/lib64/ruby/site_ruby/1.8/x86_64-linux


Comment 6 Jesse Keating 2006-07-10 15:51:35 EDT
Ping.  A mass rebuild is scheduled for tomorrow, July 11th.  Please try to have
your package fixed by then.
Comment 7 Joe Orton 2006-07-13 07:46:39 EDT
Finally fixed in Raw Hide, sorry for the delay.

Note You need to log in before you can comment on or make changes to this bug.