Bug 1916297 - [OCP4] all of the OCP master nodes with soft-anti-affinity run on the same OSP node
Summary: [OCP4] all of the OCP master nodes with soft-anti-affinity run on the same OS...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Pierre Prinetti
QA Contact: Pedro Amoedo
URL:
Whiteboard:
Depends On: 1909587 1924670
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-14 13:50 UTC by OpenShift BugZilla Robot
Modified: 2021-03-17 16:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-22 13:54:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4550 0 None closed Bug 1916297: openstack: Create Control plane nodes sequentially 2021-02-15 09:46:24 UTC
Red Hat Product Errata RHBA-2021:0510 0 None None None 2021-02-22 13:54:47 UTC

Comment 12 weiwei jiang 2021-02-18 07:04:07 UTC
Checked with 4.6.0-0.nightly-2021-02-18-023540, and move to verified.

# openstack server group show wj46ios218ax-rpp2d-master 
+----------+------------------------------------------------------------------------------------------------------------------+
| Field    | Value                                                                                                            |
+----------+------------------------------------------------------------------------------------------------------------------+
| id       | c7ec368f-5576-4b84-86ab-50fdd6cf8701                                                                             |
| members  | 27cbf35c-d811-414e-9cc1-ce8a61e11e70, adf4783e-987f-48a9-81a4-2f2c4d4bead4, ba936b5a-6b08-48cb-b63c-906c4cd87c8f |
| name     | wj46ios218ax-rpp2d-master                                                                                        |
| policies | soft-anti-affinity                                                                                               |
+----------+------------------------------------------------------------------------------------------------------------------+
# for i in 27cbf35c-d811-414e-9cc1-ce8a61e11e70 adf4783e-987f-48a9-81a4-2f2c4d4bead4 ba936b5a-6b08-48cb-b63c-906c4cd87c8f; do openstack server show $i -f value -c hostId; done 
d1c8b2a96ec23a1e959b1e776e17f859ec1ae2c0d07b67810a2e0e54
2bdc41f55878483467141fba5dec5dd18a5b6e5935c29d536cce6296
98722992c08492dfa1589e135c262be419e9307cb74a18a65b8dcf2f

Comment 15 errata-xmlrpc 2021-02-22 13:54:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0510

Comment 16 Robert Heinzmann 2021-03-17 16:26:50 UTC
Despite the information in the errata linked to this Bugzilla, the issue is not fixed in OpenShift 4.6.18, but only in OpenShift 4.6.19.


Note You need to log in before you can comment on or make changes to this bug.