Bug 191641 - Applications cannot block screensaver
Applications cannot block screensaver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 08:03 EDT by Richard Körber
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Körber 2006-05-14 08:03:23 EDT
Description of problem:
Applications like "mplayer" or "brightside" cannot block or activate the
screensaver. The reason is that those software expects an "xscreensaver" task
and/or the "xscreensaver-command" tool, which is not provided by
"gnome-screensaver". Probably there is more software (games, TV applications,
video players) having the same issues.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.1-1.fc5.1

How reproducible:
always

Steps to Reproduce:
1. Use mplayer to play a movie (using -stop-xscreensaver option)
2. Watch the movie for several minutes

Other Steps to Reproduce:
1. Install brightside (Fedora Extras)
2. Configure it to activate or disable the screensaver by moving the mouse into
a display corner
  
Actual results:
mplayer: screenblanker is activated while watching the movie
brightside: unable to blank the screen or disable the screen blanker

Expected results:
mplayer: -stop-xscreensaver option actually disables the screen saver while the
movie is played back.
brightside: moving the mouse into a screen corner performs the appropriate action.

Additional info:
I know that this is not really a gnome-screensaver issue. Anyhow there is a lot
of software expecting xscreensaver to be running, so there should be some kind
of downward compatibility.
Comment 1 Ray Strode [halfline] 2008-03-18 14:34:27 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.