Bug 191657 - X server crashes if vnc driver is loaded
X server crashes if vnc driver is loaded
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 14:45 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-27 05:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-05-14 14:45:16 EDT
Description of problem:
If I add 'Load "vnc"' to the 

Version-Release number of selected component (if applicable):
synaptics-0.14.4-6
xorg-x11-server-Xorg-1.0.99.903-1
xorg-x11-drv-keyboard-1.1.0-1
xorg-x11-drv-mouse-1.1.0-1
xorg-x11-drv-nv-1.1.1-2
xorg-x11-drv-vesa-1.1.0-1
vnc-server-4.1.1-38

How reproducible:
Every time

Steps to Reproduce:
1.Add Load "vnc" to xorg.conf
2.Restart X

Actual results:
It won't start.  /var/log/Xorg.0.log ends with:


   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x90) [0x4783b0]
1: /lib64/libc.so.6 [0x30e072f620]
2: /usr/lib64/xorg/modules/extensions/libvnc.so [0x2aaaab88a046]
3: /usr/bin/Xorg(miWindowExposures+0xfa) [0x4c4f2a]
4: /usr/bin/Xorg [0x48515a]
5: /usr/bin/Xorg(MapWindow+0x3b6) [0x4358a6]
6: /usr/bin/Xorg(main+0x406) [0x431186]
7: /lib64/libc.so.6(__libc_start_main+0xf4) [0x30e071cf34]
8: /usr/bin/Xorg(FontFileCompleteXLFD+0xa9) [0x4304d9]

Fatal server error:
Caught signal 11.  Server aborting


Expected results:
It works with earlier releases.  If I downgrade rawhide to the following rpms,
it works again:

synaptics-0.14.4-4.2.1.x86_64.rpm
xorg-x11-drv-keyboard-1.0.1.3-1.2.x86_64.rpm
xorg-x11-drv-mouse-1.0.4-1.x86_64.rpm
xorg-x11-drv-nv-1.0.1.5-3.1.x86_64.rpm
xorg-x11-drv-vesa-1.0.1.3-1.2.x86_64.rpm
xorg-x11-server-Xorg-1.0.1-9.x86_64.rpm

The problem occurs with both nv and vesa as the main drivers.  I could try
radeon as well, but this used to freeze the entire machine hard as soon as I
connected from a vnc client, so I won't even bother.

Additional info:
This problem with vnc started on April 10, as mentioned in bug 186442.  There
have been X and vnc updates since that date, but none that fixed the problem.
Comment 1 Alexandre Oliva 2006-05-27 05:18:57 EDT
This is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.