Bug 191660 - yelp fails to build using mock
Summary: yelp fails to build using mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yelp   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-14 19:04 UTC by Alexander Täschner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.15.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 18:28:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log (11.54 KB, text/plain)
2006-05-14 19:04 UTC, Alexander Täschner
no flags Details
config.log of yelp (59.55 KB, text/plain)
2006-05-14 20:17 UTC, Alexander Täschner
no flags Details
config.log of sucessful build (133.02 KB, application/octet-stream)
2006-05-15 17:26 UTC, Alexander Täschner
no flags Details

Description Alexander Täschner 2006-05-14 19:04:27 UTC
Building the SRPM
http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fedora/RPMS/yelp-2.14.0-1.i386.rpm
using mock fails.

Attached is the build.log.

Comment 1 Alexander Täschner 2006-05-14 19:04:27 UTC
Created attachment 129014 [details]
mock build log

Comment 2 Alexander Täschner 2006-05-14 20:17:29 UTC
Created attachment 129015 [details]
config.log of yelp

According to the config.log (see attachment) the three packages
libgnomeprint-2.2, libgnomeprintui-2.2, and libstartup-notification-1.0
are missing. Since I cannot find them with yum, I do not know from
where they should come.

Comment 3 Brian Pepple 2006-05-14 21:35:56 UTC
Alex, they would be startup-notification-devel & libgnomeprintui22-devel (which
should also pull in the libgnomeprint-2.2 package).

In the future to find the *.pc files just run 'yum whatprovides
libstartup-notification-1.0.pc'

Comment 4 Alexander Täschner 2006-05-15 17:26:44 UTC
Created attachment 129100 [details]
config.log of sucessful build

Adding the line

BuildRequires: libgnomeprintui22-devel startup-notification-devel libXt-devel

to the yelp.spec solves the build problems using mock (thanks Brian!).

Attached is the config.log.


Note You need to log in before you can comment on or make changes to this bug.