Bug 1916772 - Metal3 deployment not consuming cluster-wide proxy settings
Summary: Metal3 deployment not consuming cluster-wide proxy settings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.z
Assignee: Kiran Thyagaraja
QA Contact: Victor Voronkov
URL:
Whiteboard:
: 1915802 (view as bug list)
Depends On: 1936544
Blocks: dit
TreeView+ depends on / blocked
 
Reported: 2021-01-15 15:18 UTC by Mario Vázquez
Modified: 2021-11-02 06:21 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-20 11:52:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 808 0 None open [release-4.6] Bug 1916772: Inject the cluster-wide proxy environment variables in the baremetal pod 2021-04-21 15:40:18 UTC
Red Hat Product Errata RHBA-2021:1521 0 None None None 2021-05-20 11:53:02 UTC

Description Mario Vázquez 2021-01-15 15:18:03 UTC
Description of problem:

In an environment where we need the proxy to download the RHCOS images we are hitting the following issues:

1. We have a proxy configured in the install-config.yaml.
2. The coreos-downloader container running on the Bootstrap VM is able to pull the RHCOS images.
3. Once the cluster is deployed, the metal3 pod fails to initialize. The container metal3-machine-os-downloader cannot pull the RHCOS images.

It seems that the metal3 deployment is not consuming the cluster-wide proxy configuration.

We tried to rsh into the container and as expected, when setting the https proxy everything works as expected: 

sh-4.4# curl https://mirror.openshift.com/pub/openshift-v4/dependencies/rhcos/latest/latest/rhcos-4.6.8-x86_64-openstack.x86_64.qcow2.gz                                                                              

sh-4.4#

sh-4.4#

sh-4.4# https_proxy=http://192.168.1.10:3128 curl https://mirror.openshift.com/pub/openshift-v4/dependencies/rhcos/latest/latest/rhcos-4.6.8-x86_64-openstack.x86_64.qcow2.gz -O                                     

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0  844M    0  864k    0     0   850k      0  0:16:57  0:00:01  0:16:56  849k^C


Version-Release number of selected component (if applicable):

4.6.8

How reproducible:
Always

Steps to Reproduce:
Stated in the description

Actual results:
Metal3 pod fails to initialize

Expected results:
Metal3 pod initializes

Additional info:

Comment 2 sdasu 2021-01-19 17:31:29 UTC
*** Bug 1915802 has been marked as a duplicate of this bug. ***

Comment 7 Yaniv Joseph 2021-03-08 13:45:43 UTC
Copy Interwhiteboard annotation from https://bugzilla.redhat.com/show_bug.cgi?id=1915802.

Comment 17 errata-xmlrpc 2021-05-20 11:52:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.29 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1521


Note You need to log in before you can comment on or make changes to this bug.