Bug 191678 - Initscripts fails to build in Mock
Summary: Initscripts fails to build in Mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
: 192509 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-15 03:57 UTC by Brian Pepple
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 01:38:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mock Build Log Failure (5.04 KB, text/plain)
2006-05-15 03:57 UTC, Brian Pepple
no flags Details
Makefile patch to reposition pkg-config calls (1009 bytes, patch)
2006-05-16 20:15 UTC, Andreas Thienemann
no flags Details | Diff

Description Brian Pepple 2006-05-15 03:57:39 UTC
Description of problem: Initscripts fails to build in Mock

Comment 1 Brian Pepple 2006-05-15 03:57:40 UTC
Created attachment 129032 [details]
Mock Build Log Failure

Comment 2 Bill Nottingham 2006-05-16 20:12:04 UTC
From the spec:

BuildPrereq: glib2-devel popt gettext pkgconfig

I'm not sure how you're getting this error.

Comment 3 Andreas Thienemann 2006-05-16 20:15:07 UTC
Created attachment 129269 [details]
Makefile patch to reposition pkg-config calls

I've got a patch, which works by changing the position of the `pkg-config` call
in the makefile.

I have _ABSOFUCKINGLUTELY_ no clue why this should matter, but hey... It works
for me.
With this, initscripts compiles in mock.

Comment 4 Bill Nottingham 2006-05-16 20:19:30 UTC
That change switches it to link glib2 into the apps dynamically instead of
statically - initscripts needs to link it statically as those apps are in /sbin
and may be run before /usr is available (where the glib libraries are.)

It appears that glib lost its static libraries in rawhide. Any reason why?


Comment 5 Bill Nottingham 2006-05-22 15:36:40 UTC
*** Bug 192509 has been marked as a duplicate of this bug. ***

Comment 6 Matthias Clasen 2006-05-24 01:38:12 UTC
glib lost its static libraries in accordance to the general policy of not shipping
static libraries. To fix initscripts and pam, I have moved glib to /lib now.


Note You need to log in before you can comment on or make changes to this bug.