Bug 1916860 - Display incompatible helm charts for installation (kubeVersion of cluster doesn't meet requirements of chart)
Summary: Display incompatible helm charts for installation (kubeVersion of cluster doe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.z
Assignee: Predrag Knezevic
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1891314
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-15 16:49 UTC by Predrag Knezevic
Modified: 2021-03-16 23:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1891314
Environment:
Version: 4.6.0-0.nightly-2020-10-03-051134 Cluster ID: d189d8ef-1961-4aff-b73c-afbf2ead94ff Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.80 Safari/537.36
Last Closed: 2021-03-16 23:22:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 7851 0 None open Bug 1916860: Filter out helm charts based on kubernetes version 2021-02-05 19:18:23 UTC
Red Hat Product Errata RHBA-2021:0753 0 None None None 2021-03-16 23:22:34 UTC

Comment 1 Andrew Ballantyne 2021-01-15 17:06:13 UTC
@pknezevi@redhat.com do we have a PR up for this? Looks like the auto cherry-pick in Dec failed.

Comment 2 Predrag Knezevic 2021-01-18 10:15:17 UTC
(In reply to Andrew Ballantyne from comment #1)
> @pknezevi@redhat.com do we have a PR up for this? Looks like the auto
> cherry-pick in Dec failed.

Yes, the link to PR is attached to this ticket.

Comment 9 spathak@redhat.com 2021-03-09 12:40:07 UTC
Kubernetes Version for 4.5.10 was v1.18.3+b0068a8 and for 4.6.0-0.nightly-2021-03-06-050044 build was v1.19.0+2f3101c.

I found following charts missing in 4.6 build 
Examples:
Ibm Cpq Prod v4.0.0
Ibm Object Storage Plugin v2.0.0
Quarkus v0.0.3
Nodejs Ex K v0.1.1 etc.

As we know that Helm page only displays the charts that are compatible with the kubernetes version of the OpenShift Cluster and above charts were missing in 4.6 cluster which were present in 4.5.10.

Verified on build version: 4.6.0-0.nightly-2021-03-06-050044
Browser version: Chrome 84

Comment 11 errata-xmlrpc 2021-03-16 23:22:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0753


Note You need to log in before you can comment on or make changes to this bug.