Bug 191711 - Problem with system-config-display on sun fire v40z (FC4/x86_64)
Problem with system-config-display on sun fire v40z (FC4/x86_64)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 08:42 EDT by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 10:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2006-05-15 08:42:11 EDT
Description of problem:
Having problems to configure the video card in a sun fire V40Z (4x amd opteron
dial core; Hardware platform: x86_64) in FC4:
The system-config-display is rejected:
======================================

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-22.18.bz155725.ELsmp x86_64 [ELF]
Current Operating System: Linux lindb.rhrk.uni-kl.de 2.6.16-1.2096_FC4smp #1 SMP
Wed Apr 19 16:01:54 EDT 2006 x86_64
Build Date: 02 May 2006
Build Host: hs20-bc1-1.build.redhat.com

        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.16-1.2096_FC4smp
(bhcompile@hs20-bc1-1.build.redhat.com) (gcc version 4.0.2 20051125 (Red Hat
4.0.2-8)) #1 SMP Wed Apr 19 16:01:54 EDT 2006 M
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Mon May 15 14:35:47 2006
(++) Using config file: "/tmp/tmp8B1WbRxorg.config"
(WW) TRIDENT(0): Failed to set up write-combining range (0xfd800000,0x800000)
Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/dev/null" for additional information.
=========================================================================

This happens if for a long time there has been no input on a display.

Video card: VGA compatible controller: Trident Microsystems Blade 3D PCI/AGP
(rev 3a)

Version-Release number of selected component (if applicable):
system-config-display-1.0.29-1

How reproducible:


Steps to Reproduce:
1.system-config-display
2.
3.
  
Actual results:
The screen is sometimes blinking, then an error msg appears.


Expected results:
The display is configured correctly

Additional info:
Comment 1 Mike A. Harris 2006-06-27 10:31:17 EDT
>Fatal server error:
>could not open default font 'fixed'

This isn't a bug, it's a misconfiguration or local system issue.  You
can find more information about this by googling for the error message.
If you're unable to source the problem and correct it, you might want
to ask for help on the xorg@lists.freedesktop.org mailing list, where
others can help isolate the misconfiguration and assist in correcting
the problem.

The reason the screen is blinking is because the X server is restarting
in an endless loop, and failing again due to font subsystem problems, but
that is not a video problem.




Note You need to log in before you can comment on or make changes to this bug.