Bug 191715 - Can't install OS on SCSI system
Can't install OS on SCSI system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 09:25 EDT by Joseph Perrin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 23:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anaconda.log (6.02 KB, text/plain)
2006-05-15 09:52 EDT, Joseph Perrin
no flags Details
The file: /tmp/syslog (11.25 KB, text/plain)
2006-05-15 15:20 EDT, Joseph Perrin
no flags Details

  None (edit)
Description Joseph Perrin 2006-05-15 09:25:47 EDT
Description of problem:
Installation of FC5 fails to find any system disks to install on.  


Version-Release number of selected component (if applicable):
Adaptec: 29160-U

How reproducible:
Each install attempt!


Steps to Reproduce:
1. Begin FC5 install via CD (non-SCSI)  I choose "Skip", (Media is fine),
"English"...
2. It says: "Warning: No hard drives have been found.  You probably need to
manually..."  I say "Yes".
3. I choose "Add Device", and pick "Adaptec 29xx series (aic7xxx)", and say "Done".
4. After it searches for existing installations, it fails with: "No drives Found".
  
Actual results:
A simple upgrade is now an extended downed server.  :-(


Expected results:
Need I say it?


Additional info:
Had similar goofy FC5 install issues on a machine with an Adaptec AVA-2906 card,
(for a scanner).  I had to physically remove the card to install OS.  Can't
easily do that in this case.  ;-)  (Or is that the whole point?)
Comment 1 David Cantrell 2006-05-15 09:31:05 EDT
Can you attach /tmp/anaconda.log?
Comment 2 Joseph Perrin 2006-05-15 09:52:05 EDT
Created attachment 129056 [details]
/tmp/anaconda.log
Comment 3 Jeremy Katz 2006-05-15 14:52:23 EDT
Can you also attach /tmp/syslog?
Comment 4 Joseph Perrin 2006-05-15 15:20:44 EDT
Created attachment 129110 [details]
The file: /tmp/syslog
Comment 5 Joseph Perrin 2006-05-15 15:57:06 EDT
I've heard some discussions about this being a BIOS related issue.  The BIOS on
the Adaptec is up to snuff, but the MB is another question.  I'm flashing it
just to make sure.  It certainly can't hurt!
Comment 7 Joseph Perrin 2006-05-16 12:40:01 EDT
*Any* useful status update would be greatly appreciated.  Tell me to bag my SCSI
gear if it means I'll be up any time soon!
Comment 8 Joseph Perrin 2006-05-18 18:31:17 EDT
After bagging my SCSI hardware, (which pissed me off greatly), I bought 2 new
IDE disks, which then worked.  *However*, after successfully loading OS, my NIC
card couldn't be found.  Seriously folks, It's a 3c59x...  I put 7 different
brands of NIC card in that machine, and BIOS finds all of 'em, but this
stinkining OS doesn't see a blasted thing!  FC4 finds them just fine, FC3, FC1,
RH9, RH8 all find them.  --My Dog can even find 'em!  It's clear FC5 is PCI blind!  

After a couple of hundred dollars in new hardware, bought out of desperation and
now *two* weeks offline, I need a frickin' work around so I can get this blasted
web server back online!  At some point you have to give *back* some information!
 Now is the time!  I've been around since kernel 0.96, but I'm *so* completely
disappointed as of late.  :-(
Comment 9 Joseph Perrin 2006-05-18 23:13:53 EDT
Fixed by boot kernel option: pci=noacpi.  Something must've changed that broke
this in FC5!

Note You need to log in before you can comment on or make changes to this bug.