Bug 1917391 - python-pymatreader: FTBFS in Fedora rawhide
Summary: python-pymatreader: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pymatreader
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1969091 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall F34FTBFS PYTHON3.10 1914283
TreeView+ depends on / blocked
 
Reported: 2021-01-18 12:09 UTC by Tomáš Hrnčiar
Modified: 2021-07-06 14:34 UTC (History)
3 users (show)

Fixed In Version: python-pymatreader-0.0.24-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 14:34:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-18 12:09:49 UTC
Description of problem:
Package python-pymatreader fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.0.24-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-pymatreader-0.0.24-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-pymatreader

======================================================================
ERROR: tests.test_pymatreader.test_eeglab_v7v73
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/test_pymatreader.py", line 172, in test_eeglab_v7v73
    assertDeepAlmostEqual(v7_data, v73_data)
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 74, in assertDeepAlmostEqual
    assertDeepAlmostEqual(expected[key], actual[key],
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 74, in assertDeepAlmostEqual
    assertDeepAlmostEqual(expected[key], actual[key],
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 66, in assertDeepAlmostEqual
    assert_equal(len(expected), len(actual))
TypeError: object of type 'NoneType' has no len()

======================================================================
ERROR: tests.test_pymatreader.test_eeglab_epochs
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/test_pymatreader.py", line 245, in test_eeglab_epochs
    assertDeepAlmostEqual(old_data, new_data)
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 74, in assertDeepAlmostEqual
    assertDeepAlmostEqual(expected[key], actual[key],
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 74, in assertDeepAlmostEqual
    assertDeepAlmostEqual(expected[key], actual[key],
  File "/builddir/build/BUILD/pymatreader-00041deb731dffdfbbf457b9c05ae680d21a7234/tests/helper_functions/__init__.py", line 66, in assertDeepAlmostEqual
    assert_equal(len(expected), len(actual))
TypeError: object of type 'NoneType' has no len()

----------------------------------------------------------------------
Ran 18 tests in 18.012s

FAILED (errors=2)

Comment 1 Fedora Release Engineering 2021-01-24 04:23:02 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-15).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Ben Cotton 2021-02-09 15:41:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Miro Hrončok 2021-06-04 20:13:17 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Miro Hrončok 2021-06-07 22:58:08 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 5 Miro Hrončok 2021-06-08 11:30:35 UTC
*** Bug 1969091 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.