Bug 1917418 - python-streamlink fails to build with new RTD theme: pushd: build/sphinx/html/_static/fonts/: No such file or directory
Summary: python-streamlink fails to build with new RTD theme: pushd: build/sphinx/html...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-streamlink
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-18 13:11 UTC by Tomáš Hrnčiar
Modified: 2021-01-19 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-19 10:46:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-18 13:11:46 UTC
Description of problem:
Package python-streamlink fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.7.0-1.fc34

Steps to Reproduce:
koji build --scratch f34 python-streamlink-1.7.0-1.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-streamlink


The HTML pages are in build/sphinx/html.
+ rm build/sphinx/html/.buildinfo
+ pushd build/sphinx/html/_static/fonts/
/var/tmp/rpm-tmp.zk7LrN: line 43: pushd: build/sphinx/html/_static/fonts/: No such file or directory

It is caused by updated RTD scheme.
https://src.fedoraproject.org/rpms/python-streamlink/blob/master/f/python-streamlink.spec#_92


Note You need to log in before you can comment on or make changes to this bug.