Bug 1917506 - Cannot delete content hosts registered before 6.9 upgrade
Summary: Cannot delete content hosts registered before 6.9 upgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.9.0
Assignee: Jonathon Turel
QA Contact: tstrych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-18 15:43 UTC by Jonathon Turel
Modified: 2021-12-09 15:53 UTC (History)
5 users (show)

Fixed In Version: foreman-2.3.1.10-1
Doc Type: Known Issue
Doc Text:
Content hosts registered prior to Satellite 6.9 upgrade cannot be deleted / unregistered; it produces the following error: “ERROR: update or delete on table "hosts" violates foreign key constraint”.
Clone Of:
Environment:
Last Closed: 2021-03-08 16:30:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 31669 0 Normal Closed registration_facet missing on hosts 2021-02-15 03:13:33 UTC

Description Jonathon Turel 2021-01-18 15:43:09 UTC

Comment 1 Jonathon Turel 2021-01-18 15:43:14 UTC
Created from redmine issue https://projects.theforeman.org/issues/31669

Comment 2 Jonathon Turel 2021-01-18 15:43:16 UTC
Upstream bug assigned to jturel

Comment 3 Jonathon Turel 2021-01-18 15:46:20 UTC
There may be other issues fixed by this but the report we received from our user states that existing content hosts (prior to 6.9 upgrade) cannot be deleted / unregistered without getting an error like this:

2021-01-15T11:20:37 [E|bac|] PG::ForeignKeyViolation: ERROR:  update or delete on table "hosts" violates foreign key constraint "fk_rails_4c747e18cb" on table "registration_facets"
 | DETAIL:  Key (id)=(8006) is still referenced from table "registration_facets".
 |  (ActiveRecord::InvalidForeignKey)

https://community.theforeman.org/t/cant-delete-any-hosts-after-upgrade-to-katello-3-18/21998

Comment 4 Bryan Kearney 2021-01-19 14:35:51 UTC
Upstream bug assigned to jturel

Comment 5 Bryan Kearney 2021-01-19 14:35:52 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/31669 has been resolved.

Comment 8 tstrych 2021-03-08 14:36:16 UTC
Hi Jonathon, can you please write me the complete reproducer steps. Firstly I would like to see the problem and then it will be reproduced with the proposed fix.
I am sorry it's not clear enough to me from comment #3

Comment 9 Jonathon Turel 2021-03-08 16:30:11 UTC
Hey Tomas, sorry for the confusion here. When I first saw the user's report I thought there was a more serious issue so I immediately cloned to bugzulla. I actually think the issue is specific to their environment and the fix delivered likely does not even affect a production environment (only dev!), so I am going to close this one out as NOTABUG considering we haven't had any similar reports from downstream or upstream.


Note You need to log in before you can comment on or make changes to this bug.