Bug 1917575 - s390x: qemu virtio serial port not created with newer kernel versions on supermin appliance (5.10.6-200.fc33.s390x and beyond)
Summary: s390x: qemu virtio serial port not created with newer kernel versions on supe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: s390x
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2021-01-18 19:37 UTC by Prashanth Sundararaman
Modified: 2021-02-01 01:52 UTC (History)
22 users (show)

Fixed In Version: kernel-5.10.11-200.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-01 01:52:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Prashanth Sundararaman 2021-01-18 19:37:52 UTC
1. Please describe the problem:
In the coreos-assembler ,we use supermin to create a qemu VM inside an F33 container (on a RHEL8 host). As part of the VM a virtioserialport is created:


https://github.com/coreos/coreos-assembler/blob/master/src/cmdlib.sh#L528

Lately, we have seen error messages like this:

```
+ tee /dev/virtio-ports/cosa-cmdout
+ bash /srv/tmp/build.qemu/cmd.sh
tee: /dev/virtio-ports/cosa-cmdout: No such file or directory
```

which seem to suggest the device is not available.

When the kernel-core and kernel-modules packages were downgraded from    5.10.7-200.fc33.s390x to 5.9.16-200.fc33.s390x, the issue was doesn't show up.

After a little bit of testing - the build this started failing was : 5.10.6-200.fc33.s390x

This also happens on f32 when going from  5.9.16-100.fc32 --> 5.10.7-100.fc32

2. What is the Version-Release number of the kernel:
5.10.7-200.fc33.s390x

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
5.10.6-200.fc33.s390x

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
create a qemu VM with a virtio serial port and try to access it.

Comment 1 Prashanth Sundararaman 2021-01-18 20:14:38 UTC
Actually I went back and tried kernel-5.10.0-98.fc33 and it had the same issue , so looks like the last build where this worked was 5.9.16-200.fc33.s390x

Comment 2 Jakub Čajka 2021-01-19 13:29:29 UTC
I think that the root cause is this change 
 - CONFIG_VIRTIO_CONSOLE=y
+ # CONFIG_VIRTIO_CONSOLE is not set 
introduced with the rebase to 5.10 in the s390x fedora configs with commit e18a08842c58c529ffcf0a8bca80776a5e14b3d5.
I'm in process to build and tests with the original kernel config option.

Comment 3 Dan Horák 2021-01-19 13:38:22 UTC
Which is caused by redhat/configs/pending-common/generic/s390x/CONFIG_VIRTIO_CONSOLE (setting N) overriding redhat/configs/common/generic/s390x/CONFIG_VIRTIO_CONSOLE (setting Y).

Comment 4 Fedora Update System 2021-01-28 16:43:08 UTC
FEDORA-2021-e04cde3ff0 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e04cde3ff0

Comment 5 Fedora Update System 2021-02-01 01:52:55 UTC
FEDORA-2021-e04cde3ff0 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.