Bug 1917683 - `NodeTextFileCollectorScrapeError` alert in OCP 4.6 cluster.
Summary: `NodeTextFileCollectorScrapeError` alert in OCP 4.6 cluster.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.0
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1928077 (view as bug list)
Depends On:
Blocks: 1928073 1928077
TreeView+ depends on / blocked
 
Reported: 2021-01-19 06:42 UTC by Rahul Rajendran
Modified: 2021-02-24 15:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-24 15:54:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift node_exporter pull 78 0 None closed Bug 1917683: Remove escape characters 2021-02-21 07:55:10 UTC
Github openshift node_exporter pull 79 0 None closed Bug 1917683: text_collectors: do not use space as a replacement for escape characters 2021-02-21 07:55:10 UTC
Red Hat Knowledge Base (Solution) 5800941 0 None None None 2021-02-15 11:46:51 UTC
Red Hat Product Errata RHSA-2020:5633 0 None None None 2021-02-24 15:54:56 UTC

Description Rahul Rajendran 2021-01-19 06:42:44 UTC
Description of problem: Alert `NodeTextFileCollectorScrapeError` is experienced in the cluster. The alert is associated with the worker nodes which are baremetal RHEL.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

The `virt.prom` shows parsing error.

Expected results:
The `virt.prom` should not cause any error.

Additional info:

Comment 4 Pawel Krupa 2021-01-22 08:52:52 UTC
> maybe we should change to
> echo "${line//\\/}" >>"${v}"

Yes, that makes sense. I already updated my PR.

> and I still doubt "-[" and "]-" are unnecessary

This is what is reported and we shouldn't manipulate data more than it is required by prometheus.

Comment 6 Junqi Zhao 2021-01-26 04:14:45 UTC
tested with 4.7.0-0.nightly-2021-01-25-212451, issue is fixed

Comment 8 Pawel Krupa 2021-02-12 10:37:11 UTC
*** Bug 1928077 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2021-02-24 15:54:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633


Note You need to log in before you can comment on or make changes to this bug.