RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1917752 - Evince does not open containing folder if file from URI is loaded (permission problem)
Summary: Evince does not open containing folder if file from URI is loaded (permission...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: evince
Version: 8.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: 8.0
Assignee: Marek Kašík
QA Contact: Bill Sanford
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-19 10:27 UTC by Radek Duda
Modified: 2021-11-09 20:01 UTC (History)
5 users (show)

Fixed In Version: evince-3.28.4-12.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-09 17:40:50 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4155 0 None None None 2021-11-09 17:40:54 UTC

Description Radek Duda 2021-01-19 10:27:51 UTC
Description of problem:
Evince does not open containing folder if file from URI is loaded. Nautilus is started and then abruptly closed.
"Do not have a permission to access requested location" message appears for a while.

Version-Release number of selected component (if applicable):
evince-3.28.4-8.el8.x86_64
nautilus-3.28.1-15.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start evince and load some pdf from URI (e.g.: evince http://www.farnell.com/datasheets/2819352.pdf)
2. Click "file options"-> "Open containing folder"

Actual results:
Nautilus is started, but then abruptly closes. "Do not have a permission to access requested location" message appears for a while.

Expected results:
Containing folder is opened by Nautilus.

Additional info:

Comment 1 Radek Duda 2021-01-19 14:01:22 UTC
That is probably issue of given wrong file permission. 
If I save pdf file to /tmp dir, evince gives 600 permission. According to our test suite it should have 644, which is default permission according to our testcase (tested with gedit).

Comment 2 Marek Kašík 2021-02-16 17:23:10 UTC
The issue is that it tries to open the original URI but it is a http:// URI so it fails. I've created a merge request which uses the tmp directory where the downloaded document is instead. See https://gitlab.gnome.org/GNOME/evince/-/merge_requests/312.

I'll wait few days whether upstream will accept it and devel_ack+ it then.

Comment 7 Bill Sanford 2021-04-16 16:18:32 UTC
Verified with evince-3.28.4-12 & nautilus-3.28.1-15.

Comment 9 errata-xmlrpc 2021-11-09 17:40:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (evince bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4155


Note You need to log in before you can comment on or make changes to this bug.