Bug 191781 - xorg-x11-server-Xorg should not be pulling in all drivers
xorg-x11-server-Xorg should not be pulling in all drivers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Blocker OLPCTracker
  Show dependency treegraph
 
Reported: 2006-05-15 14:52 EDT by David Zeuthen
Modified: 2013-03-05 22:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 10:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2006-05-15 14:52:54 EDT
Description of problem:

[davidz@daxter ~]$ rpm -q xorg-x11-server-Xorg 
xorg-x11-server-Xorg-1.0.99.902-1
[davidz@daxter ~]$ rpm -q --requires xorg-x11-server-Xorg |grep xorg-x11-drivers
xorg-x11-drivers >= 0.99.2-4

From the ChangeLog, it seems this dependecy was introduced here

 * Fri Nov 25 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-9
 - Added "Requires: xorg-x11-drivers >= 0.99.2-4" as a dependency of the Xorg
   subpackage, to ensure that anaconda installs all of the drivers during OS
   installs and upgrades, as requested by Jeremy Katz.

and while this is convenient for the installer team there are other ways to
solve those problems.

Right now it breaks in particular for OLPC which is to be based on Fedora, and
in general it's certainly doesn't help make Fedora a good choice for any other
embedded project.

Please remove the dependency on xorg-x11-drivers. Thanks.
Comment 1 Jeremy Katz 2006-05-15 17:14:24 EDT
So, we should break things for the core users of Fedora for OLPC?  That seems
like cutting off our nose to spite our face.

The problems are
1) On fresh installs, we need to (by default at least) install all X drivers so
that people can change out their hardware and not get screwed.
2) On upgrades, we need to ensure that any X drivers which in the future get
split (eg, think of a future world where radeon and old-school ati aren't in the
same driver since they really aren't the same code and so could/should be
maintained separately)

And this needs to be done outside of anaconda so that people using other
mechanisms will have things work too.  

One possible approach is to snip the requires from xorg-x11-server-Xorg ->
xorg-x11-drivers.  And then we continue for the general case to have
xorg-x11-drivers, but in specific cases, people can not install it/remove it.  I
think that would solve the OLPC case and it should also be doable for handling
the more general case.
Comment 2 David Zeuthen 2006-05-15 21:26:27 EDT
> So, we should break things for the core users of Fedora for OLPC?  
> That seems like cutting off our nose to spite our face.

Why do you think I want to break it for core users of Fedora.

> 1) On fresh installs, we need to (by default at least) install all X 
> drivers so that people can change out their hardware and not get 
> screwed.

So anaconda would pull in both xorg-x11-server-Xorg and xorg-x11-drivers.

> 2) On upgrades, we need to ensure that any X drivers which in the
> future get split (eg, think of a future world where radeon and 
> old-school ati aren't in the same driver since they really aren't
> the same code and so could/should be maintained separately)

One solution: if you want to split out xorg-x11-drv-i810 into

 xorg-x11-drv-i810
 xorg-x11-drv-i915

you simply add a Requires: xorg-x11-drv-i915 to xorg-x11-drivers
and make xorg-x11-drv-i810 Conflict: with the old xorg-x11-drivers. 
Then on updates of xorg-x11-drv-i810 the new xorg-x11-drivers will
be pulled in and that pulls in xorg-x11-drv-i915.

I'm sure there are other ways.

> One possible approach is to snip the requires from xorg-x11-server-Xorg
> -> xorg-x11-drivers.  

Uhm, that's what I suggestion in the Summary of this bug.

X team : What are your thoughts about this?

Thanks.
Comment 3 Mike A. Harris 2006-05-23 10:11:08 EDT
I have mixed thoughts.  On the one hand, for standard desktop and server
platforms, including enthusiasts and hobbyists, we have always installed
all of the video and input drivers in every release of every OS product
we have ever made.  The total hard disk space consumed by the drivers is
negligible on all modern systems, and the benefits of having them all
installed all the time make our installer and configuration tools much
simpler.

However, this does not take into consideration the needs of embedded systems
such as OLPC.  If it is a mandatory requirement, then we have to make the
change I guess, and anaconda and the rest of our tools will need to be
updated in FC6 to deal with this.

I've commented out the dependency on xorg-x11-drivers in xorg-x11-server
in FC6 now, and it is building in beehive.


Note You need to log in before you can comment on or make changes to this bug.