Bug 1918178 - Explicitly set minimum versions of python libraries
Summary: Explicitly set minimum versions of python libraries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Riccardo Pittau
QA Contact: Lubov
URL:
Whiteboard:
Depends On: 1916145
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-20 08:47 UTC by Riccardo Pittau
Modified: 2021-02-17 19:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-17 19:25:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-image pull 141 0 None closed Bug 1918178: Explicitly set minimum versions of ironic packages 2021-02-11 14:46:16 UTC
Github openshift ironic-inspector-image pull 60 0 None closed Bug 1918178: Explicitly set minimum versions of python libraries 2021-02-11 14:46:17 UTC
Red Hat Product Errata RHBA-2021:0424 0 None None None 2021-02-17 19:25:20 UTC

Description Riccardo Pittau 2021-01-20 08:47:33 UTC
For compatibility reasons between all the installed software in the ironic container images in OCP and to allow testing specific versions in the Openshift CI, we need to track minimum versions of packages installed.

Comment 3 Lubov 2021-02-07 15:57:09 UTC
Verified the versions of mentioned in pulls componenets on 4.6.0-0.nightly-2021-02-05-192240

$ oc exec -it metal3-69478f4895-p7lt7 -c metal3-ironic-conductor -- bash
[root@master-0-0 /]# rpm -qa openstack-ironic-conductor
openstack-ironic-conductor-16.0.2-0.20201105091209.193b93c.el8.noarch
[root@master-0-0 /]# rpm -qa openstack-ironic-api
openstack-ironic-api-16.0.2-0.20201105091209.193b93c.el8.noarch

$ oc exec -it metal3-69478f4895-p7lt7 -c metal3-ironic-inspector -- bash
[root@master-0-0 /]# rpm -qa openstack-ironic-inspector
openstack-ironic-inspector-10.4.1-0.20201103162859.ce6cee6.el8.noarch

Comment 7 errata-xmlrpc 2021-02-17 19:25:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0424


Note You need to log in before you can comment on or make changes to this bug.