Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 191823 - vixie-cron Missing BuildRequire on audit-libs-devel
vixie-cron Missing BuildRequire on audit-libs-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-15 18:55 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 08:52:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (332 bytes, patch)
2006-05-15 18:55 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Andreas Thienemann 2006-05-15 18:55:34 EDT
The build fails in mock because of a missing BuildRequire.

misc.c:33:22: error: libaudit.h: No such file or directory
cc1: warnings being treated as errors
misc.c: In function 'allowed':
misc.c:495: warning: implicit declaration of function 'audit_open'
misc.c:496: warning: implicit declaration of function 'audit_log_user_message'
misc.c:496: error: 'AUDIT_USER_START' undeclared (first use in this function)
misc.c:496: error: (Each undeclared identifier is reported only once
misc.c:496: error: for each function it appears in.)
make: *** [misc.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.19176 (%build)



Attached is a patch, fixing this.
Comment 1 Andreas Thienemann 2006-05-15 18:55:34 EDT
Created attachment 129137 [details]
Patch, adding the missing buildreqs
Comment 2 Jason Vas Dias 2006-05-31 19:13:55 EDT
fixed with vixie-cron-4.1-55.FC6, now in rawhide
Comment 3 John Thacker 2006-06-01 08:52:31 EDT
Fixed, builds now in mock.

Note You need to log in before you can comment on or make changes to this bug.