Bug 191828 - tux Missing BuildRequire on docbook-utils
tux Missing BuildRequire on docbook-utils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-15 19:28 EDT by Andreas Thienemann
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 20:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (345 bytes, patch)
2006-05-15 19:28 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Andreas Thienemann 2006-05-15 19:28:04 EDT
The tux srpm won't build in mock due to a missing buildreq on docbook-utils.

Attached is a patch, fixing this.
Comment 1 Andreas Thienemann 2006-05-15 19:28:04 EDT
Created attachment 129141 [details]
Patch, adding the missing buildreqs
Comment 2 Jesse Keating 2006-06-05 14:38:26 EDT
This is failing with something else now:

gcc -g -fomit-frame-pointer -O2 -Wall -I. -DINTERFACE_VERSION=3
-D_LARGEFILE64_SOURCE -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
  -c tux.c
tux.c:51: error: expected declaration specifiers or '...' before 'tux'
tux.c:51: error: expected declaration specifiers or '...' before 'action'
tux.c:51: error: expected declaration specifiers or '...' before 'req'
tux.c:55: warning: return type defaults to 'int'
tux.c: In function '_syscall2':
tux.c:74: error: storage class specified for parameter 'nr_threads'
tux.c:75: error: storage class specified for parameter 'shared_buf'
tux.c:76: error: storage class specified for parameter 'shared_idx'
tux.c:76: error: parameter 'shared_idx' is initialized
tux.c:78: error: storage class specified for parameter 'max_module_idx'
tux.c:78: error: parameter 'max_module_idx' is initialized
tux.c:79: error: storage class specified for parameter 'handle_events_array'

and on and on...
Comment 3 Dave Jones 2006-06-05 17:43:35 EDT
glibc seems to have stopped defining _syscall2 in unistd.h

Should tux carry a private declaration of this macro, or is this likely to come
back in a glibc update?
Comment 4 Jakub Jelinek 2006-06-05 17:50:17 EDT
glibc never defined these, it is glibc-kernheaders that used to define them,
originally to helplessly broken macros, later on to syscall function invocation.
That's what apps should be actually using, not sure why glibc-kernheaders no
longer defines that in <linux/unistd.h>.
Comment 5 David Woodhouse 2006-06-05 17:54:50 EDT
glibc-kernheaders is not intended for use by normal userspace programs.
Applications should use the syscall() function which glibc provides.
Comment 6 Dave Jones 2006-06-05 19:07:23 EDT
I think I've fixed this up. It's stalled on building for the s390 though.
Other archs have now built successfully.
Comment 7 Dave Jones 2006-06-05 20:00:05 EDT
fixed.

Note You need to log in before you can comment on or make changes to this bug.