Bug 191853 - too easy to wipe out GNOME
too easy to wipe out GNOME
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 23:07 EDT by Albert Cahalan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 14:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Cahalan 2006-05-15 23:07:21 EDT
Description of problem:
There is little sanity checking on RPM operations. Rightly or not,
GNOME has a tremendous dependency tree that includes all sorts of
insignificant bits of cruft. A co-worker of mine removed a package,
probably via the graphical tool. Nothing warned him that he had
just wiped out every last scrap of GNOME. Poof, and it was all gone.
After a long and fruitless search for the package name needed to
restore GNOME, he gave up and reinstalled the OS.

Version-Release number of selected component (if applicable):


How reproducible:
Probably 100%, but not really known.

Steps to Reproduce:
1. remove some minor useless thing that GNOME indirectly "needs"
2.
3.
  
Actual results:
GNOME is gone, without a trace and without warning.

Expected results:

If and only if the user is about to remove something major:

"WARNING: you about to remove 666 packages, including some that are
via 6th-level dependancy chains. This includes one or more critical
or very large packages including: gnome ..."

In text mode: make the user type "I am certain." exactly.

In the GUI: seriously, use buttons labeled "shoot foot" and
"do not shoot foot". An "OK" is not good enough because people
reflexively click it to dismiss the many unimportant dialogs.

Additional info:
Comment 1 Jeff Johnson 2006-05-17 14:40:17 EDT
There is no single command that is easily mistyped from the CLI that will remove all of GNOME.

Presumably, all GNOME packages were removed from some other tool, and your bug is with
that tool, not rpm. For tools that use rpmlib, rpm provides mechanism only, and there are
no API's that ask
    Are you really really really realluy sure that you want to do ....?
from within rpmlib. Nor should there be ...

Note You need to log in before you can comment on or make changes to this bug.