Bug 191860 - Mkisofs generates warnings and partially corrupts output filesystem image
Mkisofs generates warnings and partially corrupts output filesystem image
Status: CLOSED DUPLICATE of bug 174667
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 01:39 EDT by Philip Prindeville
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 02:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Prindeville 2006-05-16 01:39:19 EDT
Description of problem:

On two different systems both running FC5 (updated), I can run mkisofs and one
instance will generate warnings (from the same source data), where the other one
won't.

Version-Release number of selected component (if applicable):


How reproducible:

This was done while trying to edit and rebundle FC-5-i386-DVD.iso (on an x86_64
machine also running FC5).


Steps to Reproduce:
1. Unpacked FC-5-i386-DVD.iso (on an x86_64 machine)
2. Tried to rebuild the contents of Fedora/base/stage2.img
3. Generated the final .iso with those changes.  The command used was:

   mkisofs -R -J -T -v --quiet \
        -no-emul-boot -boot-load-size 4 -boot-info-table \
        -V "Fedora Code 5 (Tweaked)" -b isolinux/isolinux.bin \
        -c isolinux/boot.cat -x "lost+found" -o /var/tmp/dvd.25635.iso \
        /var/tmp/root.25635

Actual results:

The message

Unknown file type (unallocated) /var/tmp/root.25635/.. - ignoring and continuing.

is generated...  Also, when browsing the contents of Fedora/base/ contains
an unnamed file of the same size and contents as stage2.img, but the other files
that should be in the same directory (comps.xml. minstg2.img, and TRANS.TBL) are
missing.

Expected results:

No warning should be seen, nor should the the files in Fedora/base (off the .iso
image's root) be missing.

Additional info:
Comment 1 Harald Hoyer 2006-06-06 02:20:16 EDT

*** This bug has been marked as a duplicate of 174667 ***

Note You need to log in before you can comment on or make changes to this bug.