Bug 191865 - HP Laserjet 4200n prints blank pages
HP Laserjet 4200n prints blank pages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-16 03:21 EDT by Ville Ranki
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: system-config-printer-0.6.151.7-1.
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 06:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
CUPS Error log (65.78 KB, text/plain)
2006-05-16 10:22 EDT, Ville Ranki
no flags Details
testpage-a4.ps (17.82 KB, text/plain)
2006-05-16 12:16 EDT, Tim Waugh
no flags Details
PPD file (79.98 KB, application/octet-stream)
2006-05-17 03:41 EDT, Ville Ranki
no flags Details
PPD file (79.98 KB, application/octet-stream)
2006-05-17 03:42 EDT, Ville Ranki
no flags Details
testpage-a4.ps (17.82 KB, application/postscript)
2006-05-18 07:11 EDT, Tim Waugh
no flags Details

  None (edit)
Description Ville Ranki 2006-05-16 03:21:41 EDT
Description of problem:

HP Laserjet 4200n prints blank pages. The printer 
used to work a few weeks earlier on FC5 and works 
from other operating systems. Used printer config to print
A4 test page.

Version-Release number of selected component (if applicable):
1:1.2.0-1.1

CUPS log:

[16/May/2006:10:24:08 +0300] Adding start banner page "none" to job 20.
[16/May/2006:10:24:08 +0300] Job 20 queued on "SALI_LINKKI" by "root".
[16/May/2006:10:24:08 +0300] Started filter /usr/lib/cups/filter/pstops (PID
3003) for job 20.
[16/May/2006:10:24:08 +0300] Started backend /usr/lib/cups/backend/smb (PID
3004) for job 20.
Comment 1 Tim Waugh 2006-05-16 06:42:37 EDT
So this is a printer connected to a Windows machine?

How about if you print the CUPS test page?  Does that work?
Comment 2 Ville Ranki 2006-05-16 07:49:12 EDT
CUPS test page seems to work. Printing now seems to work from
gedit and openoffice also - they didn't work earlier. Maybe 
editing the printer settings without doing anything or rebooting
helped. The A4 postscript test page still prints blank though.

The printer is a network printer connected with smb.
Comment 3 Tim Waugh 2006-05-16 10:10:03 EDT
How are you printing the A4 PostScript test page -- from the
'Administration->Printing' configuration tool, system-config-printer?

Please edit /etc/cups/cupsd.conf and change the 'LogLevel' line to read:

  LogLevel debug2

Then stop CUPS:

  /sbin/service cups stop

Clear out the log file:

  >/var/log/cups/error_log

and start CUPS again:

  /sbin/service cups start

Try printing the A4 test page again, and then please attach the
/var/log/cups/error_log file.  Thanks.
Comment 4 Ville Ranki 2006-05-16 10:22:22 EDT
Created attachment 129198 [details]
CUPS Error log
Comment 5 Ville Ranki 2006-05-16 10:23:34 EDT
Log attached. I'm using system-config-printer for printing the test page.
Comment 6 Tim Waugh 2006-05-16 10:34:55 EDT
Does this print work?:

lpr -PSALI_LINKKI -oraw /usr/share/printconf/tests/testpage-a4.ps
Comment 7 Ville Ranki 2006-05-16 10:44:42 EDT
Yep, it prints out a good test page.
Comment 8 Tim Waugh 2006-05-16 11:08:25 EDT
Aha.  Sounds like this might be a pstops filter bug.

Please attach /etc/cups/ppd/SALI_LINKKI.ppd.
Comment 9 Tim Waugh 2006-05-16 12:16:15 EDT
Created attachment 129221 [details]
testpage-a4.ps

Actually the cause for this might be a bad testpage-a4.ps file.  Please save
the attached testpage-a4.ps file and print it like this:

lpr -PSALI_LINKKI testpage-a4.ps

Does the output now look as expected?  Just to confirm, the original problem
was that you were getting a blank page in _addition_ to the correctly printed
test page, wasn't it?
Comment 10 Ville Ranki 2006-05-17 03:41:53 EDT
Created attachment 129302 [details]
PPD file
Comment 11 Ville Ranki 2006-05-17 03:42:27 EDT
Created attachment 129303 [details]
PPD file
Comment 12 Ville Ranki 2006-05-17 03:56:15 EDT
The test page you attached prints also as blank. And the problem
is that only one blank paper prints when printing ps test page.
Comment 13 Tim Waugh 2006-05-18 07:11:55 EDT
Created attachment 129408 [details]
testpage-a4.ps

Please try this testpage-a4.ps file instead.
Comment 14 Ville Ranki 2006-05-18 07:30:45 EDT
This file prints correctly.
Comment 15 Fedora Update System 2006-05-22 13:52:03 EDT
Fixed in system-config-printer-0.6.151.7-1.
Comment 16 Ville Ranki 2006-05-23 06:12:32 EDT
I confirm - it works now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.