Bug 191874 - Tetex won't build in mock
Tetex won't build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 05:10 EDT by Andreas Thienemann
Modified: 2013-07-02 19:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 15:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tetex.spec diff to be build with mock (2.37 KB, patch)
2006-06-23 10:57 EDT, Mamoru TASAKA
no flags Details | Diff
mock log of tetex with my patch attached (962.62 KB, text/plain)
2006-06-23 11:00 EDT, Mamoru TASAKA
no flags Details
tetex.spec diff to be build with mock (modified) (2.28 KB, patch)
2006-06-23 12:52 EDT, Mamoru TASAKA
no flags Details | Diff
mock log of tetex with my patch attached (again) (962.82 KB, text/plain)
2006-06-23 12:55 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Andreas Thienemann 2006-05-16 05:10:39 EDT
Tetex, more specifically ptex, won't build in mock, as the system texmf path
seems to be used.

/bin/sh ./mkconf ../../kpathsea/texmf.cnf > texmf.cnf
TEXMFCNF=. make progname=ptex files="ptex.tex min10.tfm" prereq-check
make[1]: Entering directory
`/builddir/build/BUILD/tetex-src-3.0/texk/web2c/ptex-src-3.1.9'
TEXMFCNF=. ../../kpathsea/kpsewhich --progname=ptex ptex.tex min10.tfm
>/dev/null || make prereq-lose >/dev/null
You seem to be missing input files necessary to make the
basic formats (some or all of: ptex.tex min10.tfm).
Perhaps you've defined the default paths incorrectly, or
perhaps you have environment variables set pointing
to an incorrect location.  See ../kpathsea/BUGS.

If you simply do not have the files, you can
retrieve a minimal set of input files from
ftp://ftp.tug.org/tex/lib.tar.gz, mirrored on
CTAN hosts in systems/web2c.
make[2]: *** [prereq-lose] Error 1
make[1]: *** [prereq-check] Error 2
make[1]: Leaving directory
`/builddir/build/BUILD/tetex-src-3.0/texk/web2c/ptex-src-3.1.9'
make: *** [ptex-euc.fmt] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.8037 (%build)

Instead of ../../../texmf /usr/share/texmf is used, which subsequently fails.
I tried adding
--path=../../../texmf/ptex/plain/base/:../../../texmf/fonts/tfm/ptex to the
kpsewhich command, which then fails with the following:

TEXMFCNF=. make progname=ptex files="ptex.tex min10.tfm" prereq-check
make[1]: Entering directory
`/builddir/build/BUILD/tetex-src-3.0/texk/web2c/ptex-src-3.1.9'
TEXMFCNF=. ../../kpathsea/kpsewhich --progname=ptex
--path=../../../texmf/ptex/plain/base/:../../../texmf/fonts/tfm/ptex ptex.tex
min10.tfm >/dev/null || make prereq-lose >/dev/null
make[1]: Leaving directory
`/builddir/build/BUILD/tetex-src-3.0/texk/web2c/ptex-src-3.1.9'
TEXMFCNF=. ./ptex --ini --kanji=euc --progname=ptex --jobname=ptex-euc \\input
ptex.tex \\dump </dev/null
This is pTeX, Version 3.141592-p3.1.9 (euc) (Web2C 7.5.4) (INITEX)
! I can't find file `ptex.tex'.
<*> \input ptex.tex
                    \dump
Please type another input file name:
! Emergency stop.
<*> \input ptex.tex
                    \dump
No pages of output.
Transcript written on texput.log.
make: *** [ptex-euc.fmt] Error 1

The correct solution would be, to override the definitions of texmf.cnf somehow,
but as my knowledge of the tex buildprocess is limited, I couldn't find a
working way.
Comment 1 Michael A. Peters 2006-05-21 00:21:32 EDT
If I'm not mistaken, there are other issues as well - IE even if you disable
building of ptex, some of the important binaries won't get built.

Been awhile since I looked at it, but when I last tried, I was unable to get a
succesful virgin mock build - the only way was to require itself in the
BuildRequires.

The way it is expected to build really wants the texmf already installed, it may
be necessary to package the texmf separately in different src.rpm and
BuildRequires it (which would also make updates to binaries smaller, since the
texmf and tetex-doc packages won't need to be updated for a fix to a binary bug)
Comment 2 Jindrich Novy 2006-05-30 01:42:12 EDT
Started looking into it, moving to ASSIGNED.
Comment 3 Mamoru TASAKA 2006-06-23 10:57:59 EDT
Created attachment 131439 [details]
tetex.spec diff to be build with mock

With the attached patch (for tetex.diff), I suceeded in rebuilding tetex.

I only suceeded rebuilding, and I don't have checked the binary yet.
Comment 4 Mamoru TASAKA 2006-06-23 11:00:13 EDT
Created attachment 131440 [details]
mock log of tetex with my patch attached

The log of rebuilding tetex.src by mock with my patch attached.
Comment 5 Mamoru TASAKA 2006-06-23 11:03:49 EDT
Matsuura, would you please verify the tetex rpms rebuilt from src.rpm
with my patch attached?
Comment 6 Mamoru TASAKA 2006-06-23 12:52:21 EDT
Created attachment 131449 [details]
tetex.spec diff to be build with mock (modified)

Diff file for tetex.spec is modified.
Unnecessary discription that 
"TEXMF=${RPM_BUILD_ROOT}%{_datadir}/texmf" is removed.
Comment 7 Mamoru TASAKA 2006-06-23 12:55:42 EDT
Created attachment 131450 [details]
mock log of tetex with my patch attached (again)

mock log of tetex with my patch (modified) attached.
Comment 8 Mamoru TASAKA 2006-06-24 02:43:17 EDT
Well, tetex-3.0-24.4tmp seems to work well for me.
Comment 9 Takanori MATSUURA 2006-06-24 04:10:42 EDT
(In reply to comment #6)
I also tested to build and it seems to work well.
Comment 10 Jindrich Novy 2006-06-24 15:04:25 EDT
tetex-3.0-26 is now successfully built, thanks.

Note You need to log in before you can comment on or make changes to this bug.