Bug 191882 - cannot manage all cups printers
cannot manage all cups printers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-16 06:38 EDT by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.1-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 18:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2006-05-16 06:38:14 EDT
Description of problem:
I have a cups server managing some printers attached to another system, and
printers attached to the server itself.
If i start firefox on the server and try to manage the printers, the browser
only show the printers attached to the other system: firefox localhost:631

Only if I use firefox on another machine (firefox cupsserver:631), then I see
all printers (the local attached printers too) and can manage them.


Version-Release number of selected component (if applicable):
cups-1.2.0-1.1


How reproducible:
Each time

Steps to Reproduce:
1.firefox localhost:631
2.
3.
  
Actual results:
Only the printers attached to another computer are shown

Expected results:
All printers are shown

Additional info:
New behaviour in cups-1.2.0-1.1. Had no problems in cups-1.1.23-30.2
Comment 1 Tim Waugh 2006-05-16 06:51:32 EDT
Please describe this problem in more detail.

As far as I can tell, you have two separate machines:

1. 'localhost' (showing the problem)
   with printers locally attached

and

2. 'cupsserver'
   with printers locally attached

The problem you've described is that, on localhost, running 'firefox
localhost:631' only shows printers locally attached to 'cupsserver', and does
not show the printers locally attached to 'localhost' at all.

Have I understood correctly?  If so, what does 'lpstat -t' say when you run it
on 'localhost'?
Comment 2 Joachim Backes 2006-05-17 01:04:21 EDT
lpstat -t on "cupsserver" shows _all_ printers, the locally attached printers
and the remotely attached printers.

Additionally, I can't understand your argument that "localhost:631" shows only
locally attached printers: If connecting via "localhost:631" and clicking the
button "Administration" and then the button "Manage printers", I get _ALL_
printers, and not only the locally attached ones.

Why, if connecting from another machine to "cupsserver", getting another table
of printers than if connecting locally? This seems not to be reasonable.

lpstat -t
scheduler is running
no system default destination
device for cps: lpd://aix2/cps
device for cps-a3: lpd://aix2/cps-a3
device for cps-fol: lpd://aix2/cps-fol
device for d21asc: lpd://aix2/d21asc
device for hp-a0: lpd://aix2/hp-a0
device for lj32350: socket://lj32350.rhrk.uni-kl.de:9100/
device for lpsc: ipp://lpsc:631/ipp
device for lpsc1: socket://lpsc1:9100/
device for lpsc1d: socket://lpsc1:9100/
device for lpsc1f: socket://lpsc1.rhrk.uni-kl.de:9100/
device for lpsc1t: socket://lpsc1.rhrk.uni-kl.de:9100/
device for lpsc2: lpd://lpsc2/lpsc2
device for lpsca3: ipp://lpsc:631/ipp
device for lpscbb: socket://lpsc1:9100
device for ps: lpd://aix2/ps
device for ps-a0: lpd://aix2/ps-a0
device for ps-a3: lpd://aix2/ps-a3
device for ps-eins: lpd://aix2/ps-eins
cps accepting requests since Tue May 16 10:55:47 2006
cps-a3 accepting requests since Tue May 16 14:23:05 2006
cps-fol accepting requests since Tue May 16 14:20:17 2006
d21asc accepting requests since Tue May 16 14:17:04 2006
hp-a0 accepting requests since Tue May 16 14:28:51 2006
lj32350 accepting requests since Tue May 16 10:55:47 2006
lpsc accepting requests since Tue May 16 14:40:18 2006
lpsc1 accepting requests since Tue May 16 14:41:11 2006
lpsc1d accepting requests since Tue May 16 10:55:47 2006
lpsc1f accepting requests since Tue May 16 10:55:47 2006
lpsc1t accepting requests since Tue May 16 10:55:47 2006
lpsc2 accepting requests since Tue May 16 16:20:59 2006
lpsca3 accepting requests since Tue May 16 10:55:47 2006
lpscbb accepting requests since Tue May 16 13:53:49 2006
ps accepting requests since Tue May 16 14:05:12 2006
ps-a0 accepting requests since Tue May 16 14:24:54 2006
ps-a3 accepting requests since Tue May 16 14:15:17 2006
ps-eins accepting requests since Tue May 16 14:26:07 2006
printer cps is idle.  enabled since Tue May 16 10:55:47 2006
printer cps-a3 is idle.  enabled since Tue May 16 14:23:05 2006
printer cps-fol is idle.  enabled since Tue May 16 14:20:17 2006
printer d21asc is idle.  enabled since Tue May 16 14:17:04 2006
printer hp-a0 is idle.  enabled since Tue May 16 14:28:51 2006
printer lj32350 is idle.  enabled since Tue May 16 10:55:47 2006
printer lpsc is idle.  enabled since Tue May 16 14:40:18 2006
printer lpsc1 is idle.  enabled since Tue May 16 14:41:11 2006
printer lpsc1d is idle.  enabled since Tue May 16 10:55:47 2006
printer lpsc1f is idle.  enabled since Tue May 16 10:55:47 2006
printer lpsc1t is idle.  enabled since Tue May 16 10:55:47 2006
printer lpsc2 is idle.  enabled since Tue May 16 16:20:59 2006
printer lpsca3 is idle.  enabled since Tue May 16 10:55:47 2006
printer lpscbb is idle.  enabled since Tue May 16 13:53:49 2006
printer ps is idle.  enabled since Tue May 16 14:05:12 2006
printer ps-a0 is idle.  enabled since Tue May 16 14:24:54 2006
printer ps-a3 is idle.  enabled since Tue May 16 14:15:17 2006
printer ps-eins is idle.  enabled since Tue May 16 14:26:07 2006
Comment 3 Tim Waugh 2006-05-17 06:14:28 EDT
Please describe in more words what your problem is exactly.  I don't think I
have understood.

Is it that you see different printers when doing these things?:

1. using 'firefox localhost:631' on the 'cupsserver' machine
2. using 'firefox cupsserver:631' on any other machine

Is that the problem you are describing?
Comment 4 Joachim Backes 2006-05-17 07:30:01 EDT
Hi, the problem was another one (I found out after some experimentation): The
cups browser interface shows only such printers, for which no restricted access
is set by the command "/usr/sbin/lpadmin -p <printer> -u deny:all -u
allow:<userlist>".
If I remove such restrictions by hand from /etc/cups/printers.conf, then _ALL_
printers are shown and can be administered.
Comment 5 Tim Waugh 2006-05-17 08:46:08 EDT
Okay, I see that here too.  Reported upstream:

  http://cups.org/str.php?L1700
Comment 6 Joachim Backes 2006-05-18 07:55:03 EDT
Found a workaround:

1. browser start with cupsserver:631
2. Press the tab administration
3. login via ""426 Upgrade Required"
4. Press "manage printers"
-------> Shows _ALL_ printers
Comment 7 Tim Waugh 2006-05-21 12:18:34 EDT
I think this has been fixed upstream.  1.2.0-1.4 does not contain the fix, but
the next cups package I build after that will.
Comment 8 Tim Waugh 2006-05-23 05:33:23 EDT
Please try 1.2.1-1.2 from here:

  http://people.redhat.com/twaugh/tmp/cups-fc5/

Does it work correctly for you now?
Comment 9 Joachim Backes 2006-05-23 06:27:51 EDT
Yes, it does.

Many thanks.

Regards Joachim Backes

Note You need to log in before you can comment on or make changes to this bug.