Bug 191911 - perl-XML-Simple Package fails %check in Mock
Summary: perl-XML-Simple Package fails %check in Mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-Simple   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-16 13:03 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.14-4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 18:56:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Thienemann 2006-05-16 13:03:30 UTC
The package fails the make test part in mock with Messages from XML-SAX:

+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib/lib', 'blib/arch')" t/*.t
t/0_Config........# 
# Package                        Version
#  perl                           5.8.8
#  XML::Simple                    2.14
#  Storable                       2.15
#  XML::Parser                    2.34
#  XML::SAX                       0.13
#  XML::NamespaceSupport          1.09
#  XML::SAX::PurePerl             0.90 (default parser)
ok
t/1_XMLin.........Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.

#   Failed test 'no warning issued (as expected)'
#   in t/1_XMLin.t at line 380.
#          got: 'Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
# '
#     expected: ''
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.

#   Failed test 'CDATA section parsed correctly'
#   in t/1_XMLin.t at line 426.
#     Structures begin differing at:
#          $got->{cdata} = '<greeting>Hello, world!</greeting>>'
#     $expected->{cdata} = '<greeting>Hello, world!</greeting>'

#   Failed test 'CDATA section containing markup characters parsed correctly'
#   in t/1_XMLin.t at line 432.
#     Structures begin differing at:
#          $got->{x} = '<y>one</y>><y>two</y>>'
#     $expected->{x} = '<y>one</y><y>two</y>'
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96,
<STDIN> line 1.

#   Failed test 'successfully read an SRT config file'
#   in t/1_XMLin.t at line 1443.
#     Structures begin differing at:
#          $got->{pubpath}{test1}{title} = 'web_source -> web_target1'
#     $expected->{pubpath}{test1}{title} = 'web_source -&gt; web_target1'
# Looks like you failed 4 tests of 122.
dubious
	Test returned status 4 (wstat 1024, 0x400)
DIED. FAILED tests 32, 38-39, 122
	Failed 4/122 tests, 96.72% okay
t/2_XMLout........
#   Failed test 'generated document with escaping'
#   in t/2_XMLout.t at line 302.
#     Structures begin differing at:
#          $got->{c} = '&amp;C&amp;'
#     $expected->{c} = '&C&'
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
# Looks like you failed 1 test of 196.
dubious
	Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 47
	Failed 1/196 tests, 99.49% okay (less 1 skipped test: 194 okay, 98.98%)
t/3_Storable......ok
t/4_MemShare......ok
t/5_MemCopy.......ok
t/6_ObjIntf.......ok
t/7_SaxStuff......ok
t/8_Namespaces....ok
t/9_Strict........Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
Unable to recognise encoding of this document at
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/PurePerl/EncodingDetect.pm line 96.
ok
t/A_XMLParser.....ok
Failed Test  Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/1_XMLin.t     4  1024   122    4   3.28%  32 38-39 122
t/2_XMLout.t    1   256   196    1   0.51%  47
1 subtest skipped.
Failed 2/11 test scripts, 81.82% okay. 5/468 subtests failed, 98.93% okay.
make: *** [test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.60836 (%check)

Comment 1 Matthias Clasen 2006-06-07 16:36:49 UTC
Hmm, I honestly have no idea whats going on here. I don't really speak any perl
and only own this package by accident. Jason, any idea ? And would you mind taking
this package, since you already own all of perl ?

Comment 2 Jason Vas Dias 2006-06-07 17:28:22 UTC
Hi Mathias - sure, I'll take on ownership of this package - 
please email the powers that be to change the package ownership.
I'll assign this bug to me and fix it ASAP. 
Thanks, Jason.


Comment 3 Jason Vas Dias 2006-06-07 20:52:51 UTC
For some reason, with the minimal Mock build root, the 'make test' fails
when XML::SAX::PurePerl is the default parser (being the only parser in
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/ParserDetails.ini) .
When perl-XML-LibXML and perl-XML-LibXML-Common are installed, then
XML::LibXML::SAX::Parser becomes the default parser, and the XML::Simple
'make test' then succeeds.
Yes, it sounds like a bug in XML::SAX::PurePerl, but the simple fix is for
perl-XML-Simple to 'BuildRequires: perl(XML::LibXML) perl(XML::LibXML::Common)'.
This is now the case with perl-XML-Simple-2.14-4.fc6, now in Rawhide.
  

Comment 4 Fedora Update System 2006-06-07 23:39:30 UTC
perl-XML-Simple-2.14-4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 5 Matt Domsch 2006-06-08 18:56:47 UTC
perl-XML-Simple-2.14-4.fc6.src.rpm builds on i386 and x86_64.

Comment 6 Jose Pedro Oliveira 2006-09-06 23:06:15 UTC
This email in the p5p mailing is also worth mentioning:

Subject:    Re: XML::Simple 2.14 and perl 5.8.8
http://marc.theaimsgroup.com/?l=perl5-porters&m=115757587016946&w=2


Comment 7 Jos Vos 2007-03-16 22:10:13 UTC
Exact the same problem still occurs on RHEL5 (perl-XML-Simple 2.14-4.fc6),
*even* when perl-XML-LibXML{,-Common} are installed.  Suggestions on how to
solve this?

Comment 8 Jos Vos 2007-03-19 20:36:03 UTC
I think I found the cause of (and solution for) the problem in RHEL5: see
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233003 for more details.


Note You need to log in before you can comment on or make changes to this bug.